summaryrefslogtreecommitdiff
path: root/dev-haskell/top
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-haskell/top
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/top')
-rw-r--r--dev-haskell/top/Manifest4
-rw-r--r--dev-haskell/top/files/top-1.7-ghc-7.10.patch66
-rw-r--r--dev-haskell/top/metadata.xml15
-rw-r--r--dev-haskell/top/top-1.7.ebuild35
4 files changed, 0 insertions, 120 deletions
diff --git a/dev-haskell/top/Manifest b/dev-haskell/top/Manifest
deleted file mode 100644
index 1b81c94c4e76..000000000000
--- a/dev-haskell/top/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX top-1.7-ghc-7.10.patch 2305 BLAKE2B 13dd321a0e6f4a3fd935c650361a2c65f4ac015fefe66cee4c419e9960b98ec17738cbfc679b51bfa0e3eb10eef3809d37e3d4895b91ad22147d7d2cb6c4da9a SHA512 e5b6d8ad618787e70e06ad08e92b53c5d66dd4464a7cc476f55da86b740bf835a9e3c1e35a03dd3a390bb7798459afbdf7aed19c91491bb6d16c53092cd4a0fb
-DIST Top-1.7.tar.gz 70721 BLAKE2B 90ddda99ab4dac209712494c28e15e90ffd2996151ab7df0a57fb8162bec09da6b28fd52b36672e081d10fa0b79d25bb2da2fd58d220573cea006d70c61229f0 SHA512 90d5f1042c07101c35bc1722c18667f551fa4d9034e70a4b7466ff25906899053a054f1227fed8d6d534d04fe9a1c2420585143cde44badfe98e08bf9a6225b4
-EBUILD top-1.7.ebuild 785 BLAKE2B 9e28bbc619041f8b4324d4b290a697f3e1e253d81ea62e811b64a49068496d639677928595761173b4a5b663f87285b6a5e1de97a8d5e575f0a4ff81c8886bec SHA512 2110d6b9f5f1799fc9502531724fd3481c1a57a6b6e5567101f5e6c3de110d13b09525e5a7ba63f9c05b4b30c367aa4f6ae685e9352773d515c8d87c5201a6e6
-MISC metadata.xml 662 BLAKE2B b039247722ec544417c47f53e9d7f4034e5097cc1d0874f26b735d71fa5b8a341e42f297531b15aa8fced4337dd300cf4e778406c59f58383fe74a1e8a876d9c SHA512 f335204b8139d294a18034055d76797412a4af6b98beb052878478b4246d6b2161c147fad254be262fd7732d96affe9952f231311debbd2a52fa9e338f0267be
diff --git a/dev-haskell/top/files/top-1.7-ghc-7.10.patch b/dev-haskell/top/files/top-1.7-ghc-7.10.patch
deleted file mode 100644
index 3acbda19e171..000000000000
--- a/dev-haskell/top/files/top-1.7-ghc-7.10.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-diff --git a/src/Top/Implementation/TypeGraph/DefaultHeuristics.hs b/src/Top/Implementation/TypeGraph/DefaultHeuristics.hs
-index 2cc5210..faf4c8c 100644
---- a/src/Top/Implementation/TypeGraph/DefaultHeuristics.hs
-+++ b/src/Top/Implementation/TypeGraph/DefaultHeuristics.hs
-@@ -1,2 +1,3 @@
-+{-# LANGUAGE FlexibleContexts #-}
- -----------------------------------------------------------------------------
- -- | License : GPL
-diff --git a/src/Top/Monad/Select.hs b/src/Top/Monad/Select.hs
-index e5953cb..72276b4 100644
---- a/src/Top/Monad/Select.hs
-+++ b/src/Top/Monad/Select.hs
-@@ -16,4 +16,6 @@ module Top.Monad.Select
- import Top.Util.Embedding
- import Control.Monad.State
-+import Control.Monad
-+import Control.Applicative
-
- --------------------------------------------------------
-@@ -22,4 +24,11 @@ import Control.Monad.State
- newtype Select t m a = Select (m a)
-
-+instance Monad m => Functor (Select t m) where
-+ fmap = liftM
-+
-+instance Monad m => Applicative (Select t m) where
-+ pure = return
-+ (<*>) = ap -- defined in Control.Monad
-+
- instance Monad m => Monad (Select t m) where
- return a = Select (return a)
-@@ -43,4 +52,11 @@ select = Select
- data SelectFix (t :: (* -> *) -> *) (m :: * -> *) a = SelectFix (m a)
-
-+instance Monad m => Functor (SelectFix t m) where
-+ fmap = liftM
-+
-+instance Monad m => Applicative (SelectFix t m) where
-+ pure = return
-+ (<*>) = ap -- defined in Control.Monad
-+
- instance Monad m => Monad (SelectFix t m) where
- return a = SelectFix (return a)
-diff --git a/src/Top/Monad/StateFix.hs b/src/Top/Monad/StateFix.hs
-index d77919d..bd8fb76 100644
---- a/src/Top/Monad/StateFix.hs
-+++ b/src/Top/Monad/StateFix.hs
-@@ -16,4 +16,6 @@ import Control.Monad.State
- import Control.Monad.Identity
- import Control.Monad.Writer
-+import Control.Monad
-+import Control.Applicative
-
- type StateFix s = StateFixT s Identity
-@@ -21,4 +23,11 @@ type StateFix s = StateFixT s Identity
- data StateFixT s m a = Fix { unFix :: StateT (s (StateFixT s m)) m a }
-
-+instance Monad m => Functor (StateFixT s m) where
-+ fmap = liftM
-+
-+instance Monad m => Applicative (StateFixT s m) where
-+ pure = return
-+ (<*>) = ap -- defined in Control.Monad
-+
- instance Monad m => Monad (StateFixT s m) where
- return = Fix . return
diff --git a/dev-haskell/top/metadata.xml b/dev-haskell/top/metadata.xml
deleted file mode 100644
index 20445cc8ffae..000000000000
--- a/dev-haskell/top/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
- At its most general, Top is a framework for constructing abstract interpretations
- which focuses on giving good feedback on why an abstract interpretation does not give
- any useful information. In a mathematical notation this is usually made explicit by
- returning the top element of a (complete) lattice. This is also one of the reasons
- for the name of the project.
- </longdescription>
-</pkgmetadata>
diff --git a/dev-haskell/top/top-1.7.ebuild b/dev-haskell/top/top-1.7.ebuild
deleted file mode 100644
index 284c027fe079..000000000000
--- a/dev-haskell/top/top-1.7.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.4.4.9999
-
-CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
-inherit eutils haskell-cabal
-
-MY_PN="Top"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Constraint solving framework employed by the Helium Compiler"
-HOMEPAGE="http://www.cs.uu.nl/wiki/bin/view/Helium/WebHome"
-SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="dev-haskell/mtl:=[profile?]
- dev-haskell/parsec:=[profile?]
- >=dev-lang/ghc-7.4.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.10.1.0
-"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-ghc-7.10.patch
-}