summaryrefslogtreecommitdiff
path: root/dev-haskell/top/top-1.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-haskell/top/top-1.7.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-haskell/top/top-1.7.ebuild')
-rw-r--r--dev-haskell/top/top-1.7.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-haskell/top/top-1.7.ebuild b/dev-haskell/top/top-1.7.ebuild
new file mode 100644
index 000000000000..284c027fe079
--- /dev/null
+++ b/dev-haskell/top/top-1.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit eutils haskell-cabal
+
+MY_PN="Top"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Constraint solving framework employed by the Helium Compiler"
+HOMEPAGE="http://www.cs.uu.nl/wiki/bin/view/Helium/WebHome"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10.1.0
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ghc-7.10.patch
+}