summaryrefslogtreecommitdiff
path: root/dev-haskell/th-utilities
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-haskell/th-utilities
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-haskell/th-utilities')
-rw-r--r--dev-haskell/th-utilities/Manifest3
-rw-r--r--dev-haskell/th-utilities/files/th-utilities-0.2.3.0-ghc-8.8.patch67
-rw-r--r--dev-haskell/th-utilities/th-utilities-0.2.3.0.ebuild32
3 files changed, 102 insertions, 0 deletions
diff --git a/dev-haskell/th-utilities/Manifest b/dev-haskell/th-utilities/Manifest
index 190f653e1c00..7e9646764910 100644
--- a/dev-haskell/th-utilities/Manifest
+++ b/dev-haskell/th-utilities/Manifest
@@ -1,3 +1,6 @@
+AUX th-utilities-0.2.3.0-ghc-8.8.patch 2566 BLAKE2B 3d59929531c5de3892155d836ffdbdbbe425bb959b65c2fa15fb58c5e9f083515f263717cc68e0a780dd95c476ce2c4cd504a4abc1f8f9c51f9d86b1cf10efb7 SHA512 346e3bf318d4f8aab2edfa89719a82997d91175ff11e2d649ac281269f062396f5dea9364a74ebb2ab0f78421dbc462ecea60e1b0868ad9fa08379659e446af3
DIST th-utilities-0.2.0.1.tar.gz 14996 BLAKE2B dc39e7f282a2b5cc4ae2442f76080e042bc0fd3fc28e29ef7e6313bd4685ed33c855c10fa9313e5b7d3c6e9fd3c8cfbe4a64d8131a156b34eabd0f437b99b850 SHA512 30cb5c09071beb1f8e029d217fefc6e58aa6eaa8a28994990d1549091fc174195b04a10e7873b1ac5f894cb4a528bf9764256ff1ad5c969493fbf5f872f1749f
+DIST th-utilities-0.2.3.0.tar.gz 15577 BLAKE2B fad72515936ba6b7876ff731c7a1e12246014e191282028fc1bd1846dc704d4d1408e82e82a394a1f58350f961c5b7b7f5b9ae0cfbf09551fc5964433d42b113 SHA512 edddde2ea3a9da44bd34cbf51d9f4ea14510eac9527f2f1a199390566e24f10ed84403f5450e47244b0cbfc4b5dc3a5c3f64ec596255f191d8bad83d9043a3ba
EBUILD th-utilities-0.2.0.1.ebuild 763 BLAKE2B 58d8089a1704d2439c03b3e1b88fd0f5f9a01f76ca7603fb3d90ab4e1d0a2e796e8e413c6bd77346c8641f077313a837b7fe01fbb120d5fdd23937083c361fef SHA512 b7501fe8a0bd3d90eb9cb189d1100ff652289a1fa2154b5985b86ea9f496718b7e4e7a0a16fa8c3bd29d2d3d1e8aa39d32006aab3b11a2fb9e87ceca61fa20ec
+EBUILD th-utilities-0.2.3.0.ebuild 805 BLAKE2B d4c5d4b4278513198cbbb18e501bec598c9afcbf545e66b6a14655e2baba9d3fb446ab8f62111385fd2dfc1c7e8ff003dd6419ac3018aaa9665d385c2d5e6573 SHA512 392247a11b663044fd7528e0df8018b050d7494ef2487b099ede77d4a3f0156354dad3afd222acf34831ecd0c9f5264aee850b8f982959b46e1e3a6419886bab
MISC metadata.xml 351 BLAKE2B d6d56e943b01e18fe1b9be3422620e2e59b9264c70a01c15abb29427ad82d744457ffc2fe7cc05ba8cf7c22ecff9190d1f2bdee73da42e833ac1e50e918e0a6d SHA512 22a6f9ed3b20b27470841ad774539597e351b6abd0c51fc2644c8762b7e1d08da11600c08b3cc7744984354518e046542a6409f89dac11f6c9fd0a8d87c7fb3a
diff --git a/dev-haskell/th-utilities/files/th-utilities-0.2.3.0-ghc-8.8.patch b/dev-haskell/th-utilities/files/th-utilities-0.2.3.0-ghc-8.8.patch
new file mode 100644
index 000000000000..8a3795430b1f
--- /dev/null
+++ b/dev-haskell/th-utilities/files/th-utilities-0.2.3.0-ghc-8.8.patch
@@ -0,0 +1,67 @@
+commit 5e510f6a6ed24b98d143e5baeb156a8901bf3faa
+Author: Ryan Scott <ryan.gl.scott@gmail.com>
+Date: Mon Dec 10 15:12:47 2018 -0500
+
+ Allow building with template-haskell-2.15.0.0
+
+diff --git a/src/TH/ReifySimple.hs b/src/TH/ReifySimple.hs
+index d179829..70b929e 100644
+--- a/src/TH/ReifySimple.hs
++++ b/src/TH/ReifySimple.hs
+@@ -233,18 +233,24 @@ infoToDataFamily info = case info of
+ Just $ DataFamily name (map tyVarBndrName tvs) (map go insts)
+ _ -> Nothing
+ where
+-#if MIN_VERSION_template_haskell(2,11,0)
+- go (NewtypeInstD preds name params _kind con _deriving) =
++#if MIN_VERSION_template_haskell(2,15,0)
++ go (NewtypeInstD preds _ lhs _kind con _deriving)
++ | ConT name:params <- unAppsT lhs
++#elif MIN_VERSION_template_haskell(2,11,0)
++ go (NewtypeInstD preds name params _kind con _deriving)
+ #else
+- go (NewtypeInstD preds name params con _deriving) =
++ go (NewtypeInstD preds name params con _deriving)
+ #endif
+- DataInst name preds params (conToDataCons con)
+-#if MIN_VERSION_template_haskell(2,11,0)
+- go (DataInstD preds name params _kind cons _deriving) =
++ = DataInst name preds params (conToDataCons con)
++#if MIN_VERSION_template_haskell(2,15,0)
++ go (DataInstD preds _ lhs _kind cons _deriving)
++ | ConT name:params <- unAppsT lhs
++#elif MIN_VERSION_template_haskell(2,11,0)
++ go (DataInstD preds name params _kind cons _deriving)
+ #else
+- go (DataInstD preds name params cons _deriving) =
++ go (DataInstD preds name params cons _deriving)
+ #endif
+- DataInst name preds params (concatMap conToDataCons cons)
++ = DataInst name preds params (concatMap conToDataCons cons)
+ go info' = error $
+ "Unexpected instance in FamilyI in infoToDataInsts:\n" ++ pprint info'
+
+@@ -263,8 +269,23 @@ infoToTypeFamily info = case info of
+ #endif
+ _ -> Nothing
+ where
++#if MIN_VERSION_template_haskell(2,15,0)
++ goEqn _ (TySynEqn _ lhs ty)
++ | ConT name:params <- unAppsT lhs
++ = TypeInst name params ty
++ | otherwise
++ = error $ "Unexpected type family instance head: " ++ pprint lhs
++#else
+ goEqn name (TySynEqn params ty) = TypeInst name params ty
++#endif
++
++#if MIN_VERSION_template_haskell(2,15,0)
++ go (TySynInstD (TySynEqn _ lhs ty))
++ | ConT name:params <- unAppsT lhs
++ = TypeInst name params ty
++#else
+ go (TySynInstD name (TySynEqn params ty)) = TypeInst name params ty
++#endif
+ go info' = error $
+ "Unexpected instance in FamilyI in infoToTypeInsts:\n" ++ pprint info'
+
diff --git a/dev-haskell/th-utilities/th-utilities-0.2.3.0.ebuild b/dev-haskell/th-utilities/th-utilities-0.2.3.0.ebuild
new file mode 100644
index 000000000000..ce7bbd312b27
--- /dev/null
+++ b/dev-haskell/th-utilities/th-utilities-0.2.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Collection of useful functions for use with Template Haskell"
+HOMEPAGE="https://github.com/fpco/th-utilities#readme"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/primitive:=[profile?]
+ dev-haskell/syb:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/th-orphans:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( dev-haskell/hspec
+ dev-haskell/vector )
+"
+
+PATCHES=("${FILESDIR}"/${P}-ghc-8.8.patch)