summaryrefslogtreecommitdiff
path: root/dev-haskell/th-reify-many
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/th-reify-many
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/th-reify-many')
-rw-r--r--dev-haskell/th-reify-many/Manifest5
-rw-r--r--dev-haskell/th-reify-many/metadata.xml17
-rw-r--r--dev-haskell/th-reify-many/th-reify-many-0.1.3.ebuild27
-rw-r--r--dev-haskell/th-reify-many/th-reify-many-0.1.6.ebuild27
4 files changed, 76 insertions, 0 deletions
diff --git a/dev-haskell/th-reify-many/Manifest b/dev-haskell/th-reify-many/Manifest
new file mode 100644
index 000000000000..6b80ce151712
--- /dev/null
+++ b/dev-haskell/th-reify-many/Manifest
@@ -0,0 +1,5 @@
+DIST th-reify-many-0.1.3.tar.gz 5481 BLAKE2B dbc554fbf805fc4b63a51ec17dfc8f11008072d22372ee6a52899b242fe3f138aef11ad379141a37df3cbc4c13ff0e1792edc39a16a8cad22b5641291005acb7 SHA512 1e258d9d9ae28537ce3b7eca2de2434ad1a84a474de131bc307a74d3cb6527c70ce2fa23987896e5c3804404acdfc515d08437fbdf9940b4fdab3374574a93ed
+DIST th-reify-many-0.1.6.tar.gz 5651 BLAKE2B 33a29ed0e860888d00c9d05f742c20e54916980f5e572b839b611d7ee8bae8f3e7d584fce361aa4cb8ef4107e9871513ddf07070f30f6f613326f3493c7a4d6f SHA512 dccd91f4767e29a69ad81b754085040f45a6a8ce627c435f3ca3b14cd723e390df27a462f7ba74f3d652b239c2383d84305c947ccf4fb1906ddda52f9069b589
+EBUILD th-reify-many-0.1.3.ebuild 670 BLAKE2B e6740cdb43d855a8a2520b4b0a16bdc143dc188000fda0dfea800fd8a9026b578a3c2b1b884daf8db471c6ff8b7779d49bdaa44b9cf1f6576f671493c49cc8ed SHA512 025064c8655a19e88ca73a8103c2ecc249b1ca5cba02dee8bbb9ecd80a323a6d247ed28ff236bceb538abe8e4150c69321faceb9a17e290859d89e82a3c88666
+EBUILD th-reify-many-0.1.6.ebuild 668 BLAKE2B b143b42486d4d182a037982659f30ed35bc00ba0ed99036fdcbb439e1eaacae9bb302d4f0b2294cc55f673b21fe49daeb1ce9855fd94db973cb5bae07103ca59 SHA512 067e4f2f73c7e14497a6df4b824a483b04c3860f49c4f60c2a7d0cac43d2cf7535ec3a7422c08d70e532d46c2c868ea01f5838b01a3d2035563adbd2c27582d8
+MISC metadata.xml 640 BLAKE2B 3b28ed2379e816b690ff1ef27e5cbae5e4f252b4dd0703d764aeb82a6402fa111de8a586a56b060baa8cb935b6e40a020b25546c06ba39ce55a5183b96c26c84 SHA512 611cf79c5d709a401dc3830d178911e6bd5cf223d2260fd7a424f1eb4733e1937f242473d95a81723da173ef21186fe93ee10c7944aaa9e45535073009baaea4
diff --git a/dev-haskell/th-reify-many/metadata.xml b/dev-haskell/th-reify-many/metadata.xml
new file mode 100644
index 000000000000..c5a39e2ffbb7
--- /dev/null
+++ b/dev-haskell/th-reify-many/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ @th-reify-many@ provides functions for recursively reifying top
+ level declarations. The main intended use case is for enumerating
+ the names of datatypes reachable from an initial datatype, and
+ passing these names to some function which generates instances.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">mgsloan/th-reify-many</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/th-reify-many/th-reify-many-0.1.3.ebuild b/dev-haskell/th-reify-many/th-reify-many-0.1.3.ebuild
new file mode 100644
index 000000000000..1e9c8ce7e7bb
--- /dev/null
+++ b/dev-haskell/th-reify-many/th-reify-many-0.1.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Recurseively reify template haskell datatype info"
+HOMEPAGE="https://github.com/mgsloan/th-reify-many"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ dev-haskell/safe:=[profile?]
+ dev-haskell/th-expand-syns:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
diff --git a/dev-haskell/th-reify-many/th-reify-many-0.1.6.ebuild b/dev-haskell/th-reify-many/th-reify-many-0.1.6.ebuild
new file mode 100644
index 000000000000..608c3760d633
--- /dev/null
+++ b/dev-haskell/th-reify-many/th-reify-many-0.1.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Recurseively reify template haskell datatype info"
+HOMEPAGE="https://github.com/mgsloan/th-reify-many"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ dev-haskell/safe:=[profile?]
+ dev-haskell/th-expand-syns:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"