summaryrefslogtreecommitdiff
path: root/dev-haskell/tf-random
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/tf-random
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/tf-random')
-rw-r--r--dev-haskell/tf-random/Manifest3
-rw-r--r--dev-haskell/tf-random/metadata.xml25
-rw-r--r--dev-haskell/tf-random/tf-random-0.5.ebuild26
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-haskell/tf-random/Manifest b/dev-haskell/tf-random/Manifest
new file mode 100644
index 000000000000..4ee608f84578
--- /dev/null
+++ b/dev-haskell/tf-random/Manifest
@@ -0,0 +1,3 @@
+DIST tf-random-0.5.tar.gz 18483 BLAKE2B 5fba820aa028077a1cc65e3e27b7e580f834750beb2df6dffb2488890df7e95247804a7384f18f03bb1584f5f34637bbc079b9c2445af1c6c1e3378bf0735d77 SHA512 a766909571b4b37daaaaa9fa1aa9739bd2db8c32c0f64452fd7c3717f4578090e5227b763772858c6c311c5f366dd461421ffc3beb295455902fea1fb133deb7
+EBUILD tf-random-0.5.ebuild 694 BLAKE2B 2424266e0163144b3297272a53453266e423bf16c318abb4b3602464490636dc818589026b4d158ce2c43a181e1c380eb5f2f366a57755ab15590bfa15f9e933 SHA512 dafa4e6f1beab0054a42f3a57542fa0075d7508f4b1984136230fa7263131c5cd25084086ef81a116233fcab6a414c7fc9e30fbae37a6316eacf53920d94449b
+MISC metadata.xml 1762 BLAKE2B 831805d32a97a3ecd820c9a1122cec524b3eafb3be41142b0677219d7e541d4b47ed8b22dad9fc466cfae5e301c9b469604b8a3eeafd9a1906b25dd2b91b7081 SHA512 56185586f7239dcac266f54e781e431643a80011ea73d340ac1e0bf5dd3937610d2d5433189fd59eb3736e71d3b1eeabe1a4cef804ace1369beb10b35bc93c5d
diff --git a/dev-haskell/tf-random/metadata.xml b/dev-haskell/tf-random/metadata.xml
new file mode 100644
index 000000000000..5635c16285eb
--- /dev/null
+++ b/dev-haskell/tf-random/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ This package contains an implementation of a high-quality splittable pseudorandom number generator. The generator is based on a cryptographic hash function built on top of the ThreeFish block cipher. See the paper /Splittable Pseudorandom Number Generators Using Cryptographic Hashing/ by Claessen, PaBka for details and the rationale of the design.
+
+ The package provides the following:
+
+ * A splittable PRNG that implements the standard 'System.Random.RandomGen' class.
+
+ * The generator also implements an alternative version of the 'System.Random.TF.Gen.RandomGen' class (exported from "System.Random.TF.Gen"), which requires the generator to return pseudorandom integers from the full 32-bit range, and contains an n-way split function.
+
+ * An alternative version of the @Random@ class is provided, which is linked to the new @RandomGen@ class, together with @Random@ instances for some integral types.
+
+ * Two functions for initialising the generator with a non-deterministic seed: one using the system time, and one using the @\/dev\/urandom@ UNIX special file.
+
+ The package uses an adapted version of the reference C implementation of ThreeFish from the reference package of the Skein hash function (&lt;https://www.schneier.com/skein.html&gt;), originally written by Doug Whiting.
+
+ Please note that even though the generator provides very high-quality pseudorandom numbers, it has not been designed with cryptographic applications in mind.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/tf-random/tf-random-0.5.ebuild b/dev-haskell/tf-random/tf-random-0.5.ebuild
new file mode 100644
index 000000000000..8f79546a69cb
--- /dev/null
+++ b/dev-haskell/tf-random/tf-random-0.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="lib profile" # non-ASCII in .cabal: haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="High-quality splittable pseudorandom number generator"
+HOMEPAGE="http://hackage.haskell.org/package/tf-random"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/primitive-0.3:=[profile?]
+ dev-haskell/random:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"