summaryrefslogtreecommitdiff
path: root/dev-haskell/text-stream-decode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/text-stream-decode
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/text-stream-decode')
-rw-r--r--dev-haskell/text-stream-decode/Manifest3
-rw-r--r--dev-haskell/text-stream-decode/metadata.xml14
-rw-r--r--dev-haskell/text-stream-decode/text-stream-decode-0.1.0.5.ebuild32
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-haskell/text-stream-decode/Manifest b/dev-haskell/text-stream-decode/Manifest
new file mode 100644
index 000000000000..721885ee5452
--- /dev/null
+++ b/dev-haskell/text-stream-decode/Manifest
@@ -0,0 +1,3 @@
+DIST text-stream-decode-0.1.0.5.tar.gz 12335 BLAKE2B 68c52959743e76b167f968817f128ea6e8c7d91ed091a4a19e75e7965b4dfa9d6374b21e8e68d69ccab9db95e7c431bf5736494c3923d24a1d00ea796f7eced4 SHA512 9005cc7013f56809cb0a86fa57aa6bbe97936095d100e35d86ae7e9013e0bbcced3f5522da08f5fe76585fda1e8f55b364a1ad787f9c7c7be30fae6555083a5d
+EBUILD text-stream-decode-0.1.0.5.ebuild 749 BLAKE2B 3d66f11ff67a0fd9e6fadc00a37f54df21c6bc2f5cc84ae1fcfb7263b2d208944df972db3d4f1fb7c786d99812896b3eed7523fb836589cf4d7e04adb379928f SHA512 040dfea5b15a2e9401fb217dd26cdee9c7f3c81eace09a676fdade26be8d92989280ad5cf70a495d7c0288993741977048d8a342f15df722a3180148f896ba69
+MISC metadata.xml 861 BLAKE2B 37da117b21a0d18222ba0f817b05a3385c8fdd1e5616a15eb420526b0308dad9405290399131d6eda747323cf9df3a6f6f287873ae1253cc5362d3b622393049 SHA512 9d1f9f82f3c3e75f81460cba8873f4204c5804635032a3ab3b094ecc2abc636deb2f0290fe95c6cff1177e445fa825e2a2ca23f0132e48f528c704ba5a775616
diff --git a/dev-haskell/text-stream-decode/metadata.xml b/dev-haskell/text-stream-decode/metadata.xml
new file mode 100644
index 000000000000..9b39024523a5
--- /dev/null
+++ b/dev-haskell/text-stream-decode/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ The @text@ package provides high performance functions for decoding strict and lazy @ByteString@s into @Text@. However, these functions present two issues for streaming data libraries: they throw exceptions from pure code, and are not designed for incremental consumption. This library addresses both issues with a unified API for UTF-8, -16LE, -16BE, -32LE, and -32BE. It is intended for use by high level streaming data libraries, such as conduit, enumerator, iteratee, and pipes.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">fpco/text-stream-decode</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/text-stream-decode/text-stream-decode-0.1.0.5.ebuild b/dev-haskell/text-stream-decode/text-stream-decode-0.1.0.5.ebuild
new file mode 100644
index 000000000000..6b6ff748f6e5
--- /dev/null
+++ b/dev-haskell/text-stream-decode/text-stream-decode-0.1.0.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+#hackport: flags: +text11
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Streaming decoding functions for UTF encodings. (deprecated)"
+HOMEPAGE="https://github.com/fpco/text-stream-decode"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/text-1.1:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-1.8 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=text11
+}