summaryrefslogtreecommitdiff
path: root/dev-haskell/texmath/texmath-0.8.2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/texmath/texmath-0.8.2.2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/texmath/texmath-0.8.2.2.ebuild')
-rw-r--r--dev-haskell/texmath/texmath-0.8.2.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-haskell/texmath/texmath-0.8.2.2.ebuild b/dev-haskell/texmath/texmath-0.8.2.2.ebuild
new file mode 100644
index 000000000000..269f65bc2055
--- /dev/null
+++ b/dev-haskell/texmath/texmath-0.8.2.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Conversion between formats used to represent mathematics"
+HOMEPAGE="https://github.com/jgm/texmath"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE="executable +network-uri"
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ >=dev-haskell/pandoc-types-1.12.3.3:=[profile?] <dev-haskell/pandoc-types-1.13:=[profile?]
+ >=dev-haskell/parsec-3:=[profile?]
+ dev-haskell/syb:=[profile?]
+ dev-haskell/xml:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ executable? ( dev-haskell/aeson:=[profile?]
+ dev-haskell/split:=[profile?]
+ dev-haskell/text:=[profile?] )
+ network-uri? ( >=dev-haskell/network-uri-2.6:=[profile?] )
+ !network-uri? ( <dev-haskell/network-2.6:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/temporary
+ dev-haskell/utf8-string
+ !executable? ( dev-haskell/split
+ dev-haskell/text ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable) \
+ $(cabal_flag network-uri network-uri)
+}