summaryrefslogtreecommitdiff
path: root/dev-haskell/testing-type-modifiers
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /dev-haskell/testing-type-modifiers
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'dev-haskell/testing-type-modifiers')
-rw-r--r--dev-haskell/testing-type-modifiers/Manifest3
-rw-r--r--dev-haskell/testing-type-modifiers/metadata.xml24
-rw-r--r--dev-haskell/testing-type-modifiers/testing-type-modifiers-0.1.0.1.ebuild24
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-haskell/testing-type-modifiers/Manifest b/dev-haskell/testing-type-modifiers/Manifest
new file mode 100644
index 000000000000..98170b665fe8
--- /dev/null
+++ b/dev-haskell/testing-type-modifiers/Manifest
@@ -0,0 +1,3 @@
+DIST testing-type-modifiers-0.1.0.1.tar.gz 2275 BLAKE2B 664760d4655f7c4ae4fea0b52f1687b81a754ec9d24aa940600279e6b029924b9505b29f24d7dfd07f6100e99b263727186ec8b65bd48b3d953be7554448c50b SHA512 21b76e469f2af199593a90579e9e2f0105444f508a3b244872936c95b28574cb8a782d74244249e4cf045d885b6878d8ae237ccd578c755f7314336137da56b8
+EBUILD testing-type-modifiers-0.1.0.1.ebuild 574 BLAKE2B 1d754ed7f47039737f2f74d66a8f55de99f69bbc7e31e6e63d84854823892ee7285f0829126a52be1355d060b552736edacfcb8c15a765c8c0073a14e4bb39cd SHA512 682fe7992bd18900fc4d7279e4fc8481e8a5d6b28ce457ac4ca516e196ca652cf6025be5eb7aaca4d51f8fb9515811a771d61eb132f8f2483edb3fd4dc3326b0
+MISC metadata.xml 932 BLAKE2B 5943f8307f4d7c2efb8366dbd4d2e186df5516baff1cc7695299502be5af80dd2ec9644d493b5679101e9d03039e67c023a223be819084304f0684f85234436b SHA512 99d103a5a9f86a2b462dedde3df3be4e60ae8d2957e44fe82404594513ee40618ec221dcfb5f8e86f99996c18121290c0ee37a01ba0b5d09ed720769bfb426be
diff --git a/dev-haskell/testing-type-modifiers/metadata.xml b/dev-haskell/testing-type-modifiers/metadata.xml
new file mode 100644
index 000000000000..a475c390c584
--- /dev/null
+++ b/dev-haskell/testing-type-modifiers/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Property based testing libraries such as QuickCheck tend to include type modifiers. Most of them
+ are used to quantify over subsets of a type. For example a property on non-empty lists:
+
+ @ prop_tail_length (NonEmpty xs) = length (tail xs) == length xs - 1 @
+
+ This library is intended to supply these modifiers to be used by testing libraries, in an effort to make
+ properties more portable between testing frameworks.
+
+ For every modifier it also provides an access function that converts to the underlying type, which
+ enables point-free style properties as such:
+
+ @
+ prop_tail_length2 = (&gt; 0) . length . nonEmpty
+ @
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/testing-type-modifiers/testing-type-modifiers-0.1.0.1.ebuild b/dev-haskell/testing-type-modifiers/testing-type-modifiers-0.1.0.1.ebuild
new file mode 100644
index 000000000000..dc256746b820
--- /dev/null
+++ b/dev-haskell/testing-type-modifiers/testing-type-modifiers-0.1.0.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.1
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Data type modifiers for property based testing"
+HOMEPAGE="https://hackage.haskell.org/package/testing-type-modifiers"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"