summaryrefslogtreecommitdiff
path: root/dev-haskell/testing-feat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/testing-feat
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/testing-feat')
-rw-r--r--dev-haskell/testing-feat/Manifest3
-rw-r--r--dev-haskell/testing-feat/metadata.xml23
-rw-r--r--dev-haskell/testing-feat/testing-feat-0.4.0.3.ebuild27
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-haskell/testing-feat/Manifest b/dev-haskell/testing-feat/Manifest
new file mode 100644
index 000000000000..97c038bf2eea
--- /dev/null
+++ b/dev-haskell/testing-feat/Manifest
@@ -0,0 +1,3 @@
+DIST testing-feat-0.4.0.3.tar.gz 17864 BLAKE2B ff57b181e3ed34a5e9794b9c3830122e2bd36a8199a641e2025cd5a2e467dae15cfc5d9cb4e21f198cdb667d7b9b6a5f88850f68c69d00da016200c5a12c33ce SHA512 0dabd9129472d9cf91b87a31aec9265369cdf58ec47fe74997df08097d4e93edb4f4bf52050bbca0c345e5993c12d0fcf755b94dd80093a33ba8fef366b08516
+EBUILD testing-feat-0.4.0.3.ebuild 742 BLAKE2B 7dc6e246cfa5512f866e2392a88873f4e84e44f2d2e8c5acd262757f26c318973c9f0119b420e4f28d677de016d2445863dbd9acf061fcca292322a5f971d363 SHA512 4c868ad7f8cceaa0dbef117d5b1a68b4f79cd47bef6518cf37d1c0887442e5b3e14e86bc229a9cb047aedbda1ca70f3d1e96993d35b8f0218b2994402b092df2
+MISC metadata.xml 896 BLAKE2B 4964075c0807fc2220156ac804d7d9d937f76f62b7fba6634844e70ac4961ddfa43c2868f64fde70f3a77806ee4ecdb9c1b300135059caa6f7bc1c5ddfc1359a SHA512 9b3d49257c04b2b4c836ec19aeb6c10ccf2a13a4266b65bfd31af3785d913f54f32689919c042b0d2a2d191d5bdff76b096cfbbfd48139771b5f208be7de418b
diff --git a/dev-haskell/testing-feat/metadata.xml b/dev-haskell/testing-feat/metadata.xml
new file mode 100644
index 000000000000..665eeb0f74e3
--- /dev/null
+++ b/dev-haskell/testing-feat/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Feat (Functional Enumeration of Abstract Types) provides
+ enumerations as functions from natural numbers to values
+ (similar to @toEnum@ but for any algebraic data type). This
+ can be used for SmallCheck-style systematic testing,
+ QuickCheck style random testing, and hybrids of the two.
+
+ The enumerators are defined in a very boilerplate manner
+ and there is a Template Haskell script for deriving the
+ class instance for most types.
+ "Test.Feat" contain a subset of the other modules that
+ should be sufficient for most test usage. There
+ are some small and large example in the tar
+ ball.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/testing-feat/testing-feat-0.4.0.3.ebuild b/dev-haskell/testing-feat/testing-feat-0.4.0.3.ebuild
new file mode 100644
index 000000000000..2ca1696169bb
--- /dev/null
+++ b/dev-haskell/testing-feat/testing-feat-0.4.0.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.4.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Functional Enumeration of Algebraic Types"
+HOMEPAGE="http://hackage.haskell.org/package/testing-feat"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mtl-1:=[profile?] <dev-haskell/mtl-3:=[profile?]
+ >dev-haskell/quickcheck-2:2=[profile?] <dev-haskell/quickcheck-3:2=[profile?]
+ <dev-haskell/tagshare-0.1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"