summaryrefslogtreecommitdiff
path: root/dev-haskell/tasty/tasty-1.2.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-haskell/tasty/tasty-1.2.3.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-haskell/tasty/tasty-1.2.3.ebuild')
-rw-r--r--dev-haskell/tasty/tasty-1.2.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-haskell/tasty/tasty-1.2.3.ebuild b/dev-haskell/tasty/tasty-1.2.3.ebuild
new file mode 100644
index 000000000000..bfe4addf2901
--- /dev/null
+++ b/dev-haskell/tasty/tasty-1.2.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.1
+#hackport: flags: clock
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Modern and extensible testing framework"
+HOMEPAGE="https://github.com/feuerbach/tasty"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/ansi-terminal-0.9:=[profile?]
+ >=dev-haskell/async-2.0:=[profile?]
+ >=dev-haskell/mtl-2.1.3.1:=[profile?]
+ >=dev-haskell/optparse-applicative-0.14:=[profile?]
+ >=dev-haskell/stm-2.3:=[profile?]
+ >=dev-haskell/tagged-0.5:=[profile?]
+ >=dev-haskell/unbounded-delays-0.1:=[profile?]
+ dev-haskell/wcwidth:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ >=dev-haskell/clock-0.4.4.0:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=clock
+}