summaryrefslogtreecommitdiff
path: root/dev-haskell/tar/tar-0.5.1.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-24 02:52:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-24 02:52:00 +0100
commite19b21c73e5feac42ade97baf3eeb45c58a2f234 (patch)
treef524a01a657ca0dd25be3a5bf70fbb6b694b0275 /dev-haskell/tar/tar-0.5.1.1-r2.ebuild
parentfceabcd48faf4c890719a14ac4ed93b6b7993364 (diff)
gentoo auto-resync : 24:07:2022 - 02:51:59
Diffstat (limited to 'dev-haskell/tar/tar-0.5.1.1-r2.ebuild')
-rw-r--r--dev-haskell/tar/tar-0.5.1.1-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-haskell/tar/tar-0.5.1.1-r2.ebuild b/dev-haskell/tar/tar-0.5.1.1-r2.ebuild
new file mode 100644
index 000000000000..cd48fca21e69
--- /dev/null
+++ b/dev-haskell/tar/tar-0.5.1.1-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # test-suite
+CABAL_HACKAGE_REVISION="4"
+inherit haskell-cabal
+RESTRICT="test" # Test deps need porting
+
+CABAL_FILE="${S}/${PN}.cabal"
+CABAL_DISTFILE="${P}-rev${CABAL_HACKAGE_REVISION}.cabal"
+
+DESCRIPTION="Reading, writing and manipulating \".tar\" archive files"
+HOMEPAGE="https://hackage.haskell.org/package/tar"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
+ https://hackage.haskell.org/package/${P}/revision/${CABAL_HACKAGE_REVISION}.cabal
+ -> ${CABAL_DISTFILE}"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1"
+# test? ( dev-haskell/bytestring-handle
+# >=dev-haskell/quickcheck-2 <dev-haskell/quickcheck-3
+# >=dev-haskell/tasty-0.10 <dev-haskell/tasty-1.5
+# >=dev-haskell/tasty-quickcheck-0.8 <dev-haskell/tasty-quickcheck-0.11 )
+
+BDEPEND="app-text/dos2unix"
+
+src_prepare() {
+ # pull revised cabal from upstream
+ cp "${DISTDIR}/${CABAL_DISTFILE}" "${CABAL_FILE}" || die
+
+ # Convert to unix line endings
+ dos2unix "${CABAL_FILE}" || die
+
+ # Apply patches *after* pulling the revised cabal
+ default
+}