summaryrefslogtreecommitdiff
path: root/dev-haskell/tagstream-conduit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/tagstream-conduit
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/tagstream-conduit')
-rw-r--r--dev-haskell/tagstream-conduit/Manifest3
-rw-r--r--dev-haskell/tagstream-conduit/metadata.xml17
-rw-r--r--dev-haskell/tagstream-conduit/tagstream-conduit-0.5.5.3.ebuild37
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-haskell/tagstream-conduit/Manifest b/dev-haskell/tagstream-conduit/Manifest
new file mode 100644
index 000000000000..8f8dec22c3db
--- /dev/null
+++ b/dev-haskell/tagstream-conduit/Manifest
@@ -0,0 +1,3 @@
+DIST tagstream-conduit-0.5.5.3.tar.gz 9813 BLAKE2B efacae2982642e61470312a1374b522ae5d7c2d4e2b4e115c13b246a42c910604e9d51dc9bfee6163730b4dfd35bc7f87c8e3c522b36cb7a7bcafbcbb34bf392 SHA512 84625975df6c6c315011ebfd63d551b22c00927fa9add390d9e723bc104d4a7881743aaf6bceae0ff42efc6056a314baddb594fd5e344449333ea7ff6cbcf154
+EBUILD tagstream-conduit-0.5.5.3.ebuild 1046 BLAKE2B 243f0cb0ef42ab331ba72b9ccb1136c5c98970f89204e228affe759acfd2e6e3b8c7672f17ad36c77195363cd64948ce55e87ab309cdbadf7d9a1cabad827830 SHA512 3adb3b080cae62d3ae6e418c4d52f580964361c4a6cd2fe0d450e1df76475497df8083fcc8705200b40bfaa0c66a0e74f263cf172404ea0127620d7774821e96
+MISC metadata.xml 685 BLAKE2B 473260bcbc7a73a3599594a54894f430c787b830b14aeb6a6e98262e7b367a3fe24bacacfddb2ac1511c47997e5b2dd1d721a104f703808324bfad2af2896dc6 SHA512 2169c70ea9fdcf260c56a70f5fb77661d2bc9b86a7b51dc6e97ab73ffba575ff5b6ad1ce53708f2c44493286e5f6c1e02e19863b6f0e17b3dd1fb07bf8a29963
diff --git a/dev-haskell/tagstream-conduit/metadata.xml b/dev-haskell/tagstream-conduit/metadata.xml
new file mode 100644
index 000000000000..a3fa2f565a21
--- /dev/null
+++ b/dev-haskell/tagstream-conduit/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Tag-stream is a library for parsing HTML//XML to a token stream.
+ It can parse unstructured and malformed HTML from the web.
+ It also provides an Enumeratee which can parse streamline html, which means it consumes constant memory.
+ You can start from the `tests/Tests.hs` module to see what it can do.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">yihuang/tagstream-conduit</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/tagstream-conduit/tagstream-conduit-0.5.5.3.ebuild b/dev-haskell/tagstream-conduit/tagstream-conduit-0.5.5.3.ebuild
new file mode 100644
index 000000000000..b20ef869eb29
--- /dev/null
+++ b/dev-haskell/tagstream-conduit/tagstream-conduit-0.5.5.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="streamlined html tag parser"
+HOMEPAGE="https://github.com/yihuang/tagstream-conduit"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/attoparsec-0.10:=[profile?]
+ dev-haskell/blaze-builder:=[profile?]
+ dev-haskell/case-insensitive:=[profile?]
+ >=dev-haskell/conduit-1.2:=[profile?]
+ >=dev-haskell/conduit-extra-1.1.0:=[profile?]
+ >=dev-haskell/data-default-0.5.0:=[profile?]
+ dev-haskell/resourcet:=[profile?]
+ dev-haskell/text:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-haskell/xml-conduit-1.1.0.0:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-1.3
+ dev-haskell/hunit
+ dev-haskell/quickcheck )
+"