summaryrefslogtreecommitdiff
path: root/dev-haskell/stmonadtrans
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/stmonadtrans
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/stmonadtrans')
-rw-r--r--dev-haskell/stmonadtrans/Manifest5
-rw-r--r--dev-haskell/stmonadtrans/metadata.xml17
-rw-r--r--dev-haskell/stmonadtrans/stmonadtrans-0.3.3.ebuild30
-rw-r--r--dev-haskell/stmonadtrans/stmonadtrans-0.3.4.ebuild32
4 files changed, 84 insertions, 0 deletions
diff --git a/dev-haskell/stmonadtrans/Manifest b/dev-haskell/stmonadtrans/Manifest
new file mode 100644
index 000000000000..bc12586618c5
--- /dev/null
+++ b/dev-haskell/stmonadtrans/Manifest
@@ -0,0 +1,5 @@
+DIST STMonadTrans-0.3.3.tar.gz 4820 BLAKE2B 5406412f362f9b5cb63aaae759510c5bd36b376a90b60b93849c4af42630b2a2266b708cc624b99726d49a80de9cd5c86cbf2a0ce05cd38250acc2864593dfbf SHA512 5395dfac66abcf75593b5c62252b452e4935b85e294a1f9b4a40424b29be76109b89b0cc35eaa15bd448a4d51ae0500bfe72924db854e02e949685fd9180d847
+DIST STMonadTrans-0.3.4.tar.gz 5442 BLAKE2B 748d95bc1f14e38220d2b2342a939a1a2df428c1eed11c40558eeac21566e552b1d43653a4bcb2f4c1dcdabe35352ed526cdd9a86c20acd54778154bcc71e1b2 SHA512 3799af190af51276d3cbd03908275d539dd8c290b9a48e2e9e3e41b1ea1c7d966ecddd86b93466e2fe7e63c4776e10912fa349f12aaf698a403d2e3effe59eab
+EBUILD stmonadtrans-0.3.3.ebuild 665 BLAKE2B 4c0c495ce2782100427486c7a105a283e7dd1d5915b7681d6b5fb87f9e87305812bffeb820f4806fb731dd80ec3c8cb59e9c9302b3a19b2fe9b28299a083dc08 SHA512 2e0da6edbc288104020b4db1a467482c497dcd7a5d459535cca7e66a6ec1309228538902618f8573e19f36665e17413f51f3d78ef3955c8a9918e5478ba6c5d6
+EBUILD stmonadtrans-0.3.4.ebuild 736 BLAKE2B ccc6baf6eecb3196d6271cae592bb80f7515401c952cb2960e08c03f431e0f70875d3b92aeb0ced1d0fd9a0989e22063263ed52efc876d4464b20bf301dea6c8 SHA512 0e452d76ca2fe6237961347f672a6a436b54c53b2cdcd7a90a5b59cb3acee3eab89dc2d166e91b662dd513c20a74957fae6351ded65ded75694b69d8e612bd1e
+MISC metadata.xml 736 BLAKE2B 12c1a4b31c610a16412e0a93b1a2ddec0ea04a507b44acc15a5c44fe14c7d378a98b0530fa5e4335af93f7d976c0d2148958ee142cf67bd21046114922135361 SHA512 677a9ab85a55865ca6c6a87c65ff3bad20d8e9b7c08761712a97a131c0690dd1f01417fe1d455536e33318282e6982845431bb0b3e8a35430de299620f997d1f
diff --git a/dev-haskell/stmonadtrans/metadata.xml b/dev-haskell/stmonadtrans/metadata.xml
new file mode 100644
index 000000000000..f224e9002210
--- /dev/null
+++ b/dev-haskell/stmonadtrans/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ A monad transformer version of the ST monad
+ Warning! This monad transformer should not be used with monads that
+ can contain multiple answers, like the list monad. The reason is that
+ the will be duplicated across the different answers and this cause
+ Bad Things to happen (such as loss of referential transparency). Safe
+ monads include the monads State, Reader, Writer, Maybe and
+ combinations of their corresponding monad transformers.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/stmonadtrans/stmonadtrans-0.3.3.ebuild b/dev-haskell/stmonadtrans/stmonadtrans-0.3.3.ebuild
new file mode 100644
index 000000000000..39caa6c0ea67
--- /dev/null
+++ b/dev-haskell/stmonadtrans/stmonadtrans-0.3.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="STMonadTrans"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A monad transformer version of the ST monad"
+HOMEPAGE="http://hackage.haskell.org/package/STMonadTrans"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-haskell/stmonadtrans/stmonadtrans-0.3.4.ebuild b/dev-haskell/stmonadtrans/stmonadtrans-0.3.4.ebuild
new file mode 100644
index 000000000000..5a4c6a3c3cb1
--- /dev/null
+++ b/dev-haskell/stmonadtrans/stmonadtrans-0.3.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+MY_PN="STMonadTrans"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A monad transformer version of the ST monad"
+HOMEPAGE="http://hackage.haskell.org/package/STMonadTrans"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # uses detailed-0.9 test suite, cabal fails it
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+S="${WORKDIR}/${MY_P}"