summaryrefslogtreecommitdiff
path: root/dev-haskell/skylighting-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-06 13:21:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-06 13:21:55 +0100
commit275074c50dca7b941cc7cd7966a2ace71c29ecae (patch)
treee22b9ca529098f2d687b61bc9b0eb711b0990cc3 /dev-haskell/skylighting-core
parent86b151cdc26e1566efef728aac4ebb2aabce776a (diff)
gentoo auto-resync : 06:10:2022 - 13:21:55
Diffstat (limited to 'dev-haskell/skylighting-core')
-rw-r--r--dev-haskell/skylighting-core/Manifest3
-rw-r--r--dev-haskell/skylighting-core/files/skylighting-increase-timeouts.patch39
-rw-r--r--dev-haskell/skylighting-core/skylighting-core-0.12.3.1.ebuild3
3 files changed, 43 insertions, 2 deletions
diff --git a/dev-haskell/skylighting-core/Manifest b/dev-haskell/skylighting-core/Manifest
index e6e5766cc768..c6b0ec3dc959 100644
--- a/dev-haskell/skylighting-core/Manifest
+++ b/dev-haskell/skylighting-core/Manifest
@@ -1,3 +1,4 @@
+AUX skylighting-increase-timeouts.patch 1544 BLAKE2B f85dc0a31b10437d1c368aa950f586a1a15ddba9d355b1e4ed4dd08501407825bf4c505df00e29a6f47d3f2ebb35ff36274246a93a451ce8a9d11c9b7bede22e SHA512 c7594380e39ff7d87be2d6d52ffc9c39d0676a940f06592fcb7595f2f4c778b38b35524683306c56685d34c5842f981b42586596231f1a7945fc791a8531e6d3
DIST skylighting-core-0.12.3.1.tar.gz 782536 BLAKE2B 21d908bd6f3584f7b4de91f5b61f06e9e0dffdeeb4f725f73520ae6bdfbdb482995a3453ba44db212e95585f8268aeb8535fb896f78707ab49c362675e605046 SHA512 85d005dc4fa6bf968f29a1721d669a310261052c68dbe889dc053400de751a8cda3a99a9aa7d19b3921fb81ea482637fd650140776d90207b876e639a736ef19
-EBUILD skylighting-core-0.12.3.1.ebuild 1332 BLAKE2B 095bb81cf2b8a45337eb2904801cd7cd256432eb112a6cbdd55e200385e77e063b68aae356f1157726e03dfc80091b11a6282b95a91e56ff87e6c0408c56abfe SHA512 b06888f51df2811f5b37ddae10f0023e1b44c1fbb4664deebef71eff5143f3433864582361c7e5006e4eff46a88ed7a211348e84ced76cc0a37a4712efe4822d
+EBUILD skylighting-core-0.12.3.1.ebuild 1401 BLAKE2B 4f085c65f58a42ff2abaeab63b5d1de82d3ebf822592b2f1d64ea323e92a5b9c7cf6411175fc90926e89cf5788eac3ac7011d59606afc7eb037e5fe24532389a SHA512 00a721427828ada96cab4765995188a1ba313236377017f34e99234dc97b5732b2ae0fab8433abfa9f8dbcd300a44d97913f08aebe33ed6e8d39aef8524b069e
MISC metadata.xml 857 BLAKE2B 4ca8ef30cb72a35fcb9c2005289b7450085c5128d1ae5ddbc55eb525e4a053887981f927667954f6a11bba28b597f2a47cb3f4fbd281e1eedea17dd0a3b6e9a2 SHA512 1d1738f6c98adfb33355939067c0b1786c7065d5f8c29a244f6c4ab18ee1539f97ac47d8d1a779ef0b5de5a11d871574fcdf069998e719b62893d147ce652b9c
diff --git a/dev-haskell/skylighting-core/files/skylighting-increase-timeouts.patch b/dev-haskell/skylighting-core/files/skylighting-increase-timeouts.patch
new file mode 100644
index 000000000000..8dce65f4c855
--- /dev/null
+++ b/dev-haskell/skylighting-core/files/skylighting-increase-timeouts.patch
@@ -0,0 +1,39 @@
+https://github.com/jgm/skylighting/pull/154
+
+From 00af1d629c2f185fd3c8d3eee55857b1325f345b Mon Sep 17 00:00:00 2001
+From: matoro <matoro@users.noreply.github.com>
+Date: Fri, 16 Sep 2022 10:30:35 -0400
+Subject: [PATCH] Notch up core test timeout even further
+
+On very slow/embedded cpus, 25 seconds is not sufficient (even 50
+seconds is not); I had to notch the test timeout up to 75 seconds for
+everything to pass.
+
+This disables the test timeouts completely.
+---
+ test/test-skylighting.hs | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/test/test-skylighting.hs b/test/test-skylighting.hs
+index a3977e72..0f05e573 100644
+--- a/test/test-skylighting.hs
++++ b/test/test-skylighting.hs
+@@ -224,8 +224,7 @@ p_no_drop cfg syntax t =
+
+ noDropTest :: TokenizerConfig -> [Text] -> Syntax -> TestTree
+ noDropTest cfg inps syntax =
+- localOption (mkTimeout 25000000)
+- $ testCase (Text.unpack (sName syntax))
++ testCase (Text.unpack (sName syntax))
+ $ mapM_ go inps
+ where go inp =
+ case tokenize cfg syntax inp of
+@@ -238,7 +237,7 @@ noDropTest cfg inps syntax =
+ assertFailure ("Unexpected error: " ++ e ++ "\ninput = " ++ show inp)
+
+ tokenizerTest :: TokenizerConfig -> SyntaxMap -> Bool -> FilePath -> TestTree
+-tokenizerTest cfg sMap regen inpFile = localOption (mkTimeout 25000000) $
++tokenizerTest cfg sMap regen inpFile =
+ goldenTest testname getExpected getActual
+ (compareValues referenceFile) updateGolden
+ where testname = lang ++ " tokenizing of " ++ inpFile
diff --git a/dev-haskell/skylighting-core/skylighting-core-0.12.3.1.ebuild b/dev-haskell/skylighting-core/skylighting-core-0.12.3.1.ebuild
index e9f59184a966..9e849c9733d5 100644
--- a/dev-haskell/skylighting-core/skylighting-core-0.12.3.1.ebuild
+++ b/dev-haskell/skylighting-core/skylighting-core-0.12.3.1.ebuild
@@ -15,8 +15,9 @@ SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
IUSE="executable"
+PATCHES=( "${FILESDIR}/skylighting-increase-timeouts.patch" )
RDEPEND=">=dev-haskell/aeson-1.0:=[profile?]
>=dev-haskell/ansi-terminal-0.7:=[profile?]