summaryrefslogtreecommitdiff
path: root/dev-haskell/simple-reflect
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/simple-reflect
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/simple-reflect')
-rw-r--r--dev-haskell/simple-reflect/Manifest3
-rw-r--r--dev-haskell/simple-reflect/metadata.xml14
-rw-r--r--dev-haskell/simple-reflect/simple-reflect-0.3.2.ebuild24
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-haskell/simple-reflect/Manifest b/dev-haskell/simple-reflect/Manifest
new file mode 100644
index 000000000000..edc021c5e492
--- /dev/null
+++ b/dev-haskell/simple-reflect/Manifest
@@ -0,0 +1,3 @@
+DIST simple-reflect-0.3.2.tar.gz 4492 BLAKE2B 933f9d5902a18ad3e69aa8c9731c67eb4e35aec36f860d92876d8a7709f3ced259781979bf469ca5d547e21995b84e0a94aa599f4df6e3f5fa3cbc8337e0702f SHA512 0e8e9666b10fcebbb4fe421ca8a1102d2028d8a4b2b9c196400b15ceedaa0420160e1536fadf55fdc316e1a07fb11aa92e2933b2fe491d27a1f3c54b62f268a1
+EBUILD simple-reflect-0.3.2.ebuild 584 BLAKE2B 0e5361d47f8658b08e78fe7003957a630d96cc1ae2d4b6ef93ec94b85494a23e7924fe3c28fe3ad3d60c8e25bc03a35de49e4eaa680387408e48375b1ae2022f SHA512 96e00b2ce6e534be7725a55bc940bce150a78ff717459825480fc30860a8d98a693df9b22fa2e55479110f3d30c6dfe6cbbf8a7a58b611e61693e1a67c145522
+MISC metadata.xml 592 BLAKE2B b975899549ba9e105eecbd12481245c88e5d7d8e771e4cd33b9cbfbaefa66c1b357292b7d0e5f7d2d6d8475a9ff04ae975298747b174ec219b8e901975d9319b SHA512 7a105e85491afae1d8b82be079cadf3600daafc016ed89f60365b696d340b165fa3e65e6d457d907a0fcc4a31952666eead61cdb71d9bc7080fd50f5e4fb9690
diff --git a/dev-haskell/simple-reflect/metadata.xml b/dev-haskell/simple-reflect/metadata.xml
new file mode 100644
index 000000000000..f910f43f15d1
--- /dev/null
+++ b/dev-haskell/simple-reflect/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ This package allows simple reflection of expressions containing variables.
+ Reflection here means that a Haskell expression is turned into a string.
+ The primary aim of this package is teaching and understanding;
+ there are no options for manipulating the reflected expressions beyond showing them.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/simple-reflect/simple-reflect-0.3.2.ebuild b/dev-haskell/simple-reflect/simple-reflect-0.3.2.ebuild
new file mode 100644
index 000000000000..248be3b436f7
--- /dev/null
+++ b/dev-haskell/simple-reflect/simple-reflect-0.3.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Simple reflection of expressions containing variables"
+HOMEPAGE="https://twanvl.nl/blog/haskell/simple-reflection-of-expressions"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"