summaryrefslogtreecommitdiff
path: root/dev-haskell/shelly/shelly-1.6.8.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/shelly/shelly-1.6.8.1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/shelly/shelly-1.6.8.1.ebuild')
-rw-r--r--dev-haskell/shelly/shelly-1.6.8.1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-haskell/shelly/shelly-1.6.8.1.ebuild b/dev-haskell/shelly/shelly-1.6.8.1.ebuild
new file mode 100644
index 000000000000..ab7e9c46dcc8
--- /dev/null
+++ b/dev-haskell/shelly/shelly-1.6.8.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+#hackport: flags: build-examples:examples
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="shell-like (systems) programming in Haskell"
+HOMEPAGE="https://github.com/yesodweb/Shelly.hs"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE="examples lifted"
+
+RDEPEND="dev-haskell/async:=[profile?]
+ dev-haskell/enclosed-exceptions:=[profile?]
+ >=dev-haskell/exceptions-0.6:=[profile?] <dev-haskell/exceptions-0.9:=[profile?]
+ dev-haskell/lifted-async:=[profile?]
+ dev-haskell/lifted-base:=[profile?]
+ >=dev-haskell/monad-control-0.3.2:=[profile?] <dev-haskell/monad-control-1.1:=[profile?]
+ >=dev-haskell/mtl-2:=[profile?]
+ <dev-haskell/system-fileio-0.4:=[profile?]
+ >=dev-haskell/system-filepath-0.4.7:=[profile?] <dev-haskell/system-filepath-0.5:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/transformers-base:=[profile?]
+ <dev-haskell/unix-compat-0.5:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( >=dev-haskell/hspec-1.5
+ >=dev-haskell/hunit-1.2
+ >=dev-haskell/text-0.11 )
+"
+
+PATCHES=("${FILESDIR}"/${P}-ghc-8.0.2_rc1.patch)
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'directory >= 1.1.0.0 && < 1.3.0.0' 'directory >= 1.1.0.0'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag examples build-examples) \
+ $(cabal_flag lifted lifted)
+}