summaryrefslogtreecommitdiff
path: root/dev-haskell/sha/sha-1.6.4.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-haskell/sha/sha-1.6.4.4.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-haskell/sha/sha-1.6.4.4.ebuild')
-rw-r--r--dev-haskell/sha/sha-1.6.4.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-haskell/sha/sha-1.6.4.4.ebuild b/dev-haskell/sha/sha-1.6.4.4.ebuild
new file mode 100644
index 000000000000..98ab4799ed93
--- /dev/null
+++ b/dev-haskell/sha/sha-1.6.4.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.6
+#hackport: flags: +decoderinterface
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+MY_PN="SHA"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Implementations of the SHA suite of message digest functions"
+HOMEPAGE="http://hackage.haskell.org/package/SHA"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="exe"
+
+RDEPEND=">=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( >=dev-haskell/quickcheck-2.5 <dev-haskell/quickcheck-3
+ >=dev-haskell/test-framework-0.8.0.3 <dev-haskell/test-framework-10000
+ >=dev-haskell/test-framework-quickcheck2-0.3.0.2 <dev-haskell/test-framework-quickcheck2-10000 )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=decoderinterface \
+ $(cabal_flag exe exe)
+}