summaryrefslogtreecommitdiff
path: root/dev-haskell/readargs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-haskell/readargs
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/readargs')
-rw-r--r--dev-haskell/readargs/Manifest5
-rw-r--r--dev-haskell/readargs/metadata.xml74
-rw-r--r--dev-haskell/readargs/readargs-1.2.2.ebuild37
-rw-r--r--dev-haskell/readargs/readargs-1.2.3.ebuild32
4 files changed, 0 insertions, 148 deletions
diff --git a/dev-haskell/readargs/Manifest b/dev-haskell/readargs/Manifest
deleted file mode 100644
index 988c4af12670..000000000000
--- a/dev-haskell/readargs/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-DIST ReadArgs-1.2.2.tar.gz 5102 BLAKE2B 4c1cefa9bc207d8e8473fb0e02aa5cdfef66c8b5135227ef83071325fc11f391226a15ff66e8adfa4ac6b83ebe276139a22e60df9a380c174cfb51ca0680aa5f SHA512 d6a50b4f3b97932f2edb67eb5d2af01f057b17f991f499c01c5005738cf96a55dc08453250e61a1dbbebad9c0a75c53e1caf0fbce00da5eb6c00e214595c331b
-DIST ReadArgs-1.2.3.tar.gz 5100 BLAKE2B 8d0ee19cb417a0159b9a0488f30d11319c7ce278713bbf6c0531385b6c337c2aad5f85a3d22e8559c8b13b3a89a9f42174cb53fe6e4ae2190740845c9c70002b SHA512 6fd78b26c6c0d7d2f40f1b4eef248eb55d8dc91668b578b2cf88132a364dd7741f6f4d389aeb0c80bdca7cb5dfc1524228113495a2ea3595b888eb27fb8d2dff
-EBUILD readargs-1.2.2.ebuild 908 BLAKE2B 43ce71d1b0cf80bc6eb3d33850c83c11211a0c8c7b25f6d76c1a8a1a1780eafb0425446f2981fadc59836de002e29836af5b2ee45a40e110cc0fd0f111c9ee9b SHA512 1c15e342491b6670e976b2152986cd638bd59f6a68af6fb7398ad4812baa41128fa6f7884aeaf507c83c44b7ab8002901206b6098e253a542ffcd16e59f96d67
-EBUILD readargs-1.2.3.ebuild 849 BLAKE2B a36a8b0a0612ea6284bfb1667fcb36315e45bf8f234aab7cd9862bd5f6b53afdcd4f108db3c76be6e8359e54d09457837d73f2add9d683f9e8155eeccea1e392 SHA512 ac8c42f71fdf95a384d1f04ad77830f746510d89fefeaf2c106d66c6abcfd34adf752154845ee680cc3bd634df03e806c4029327244511fc505916617503d0be
-MISC metadata.xml 2275 BLAKE2B 9fc785a8e06669573e324610295248fb18d840cd2b3dc5559c7e6d8ad0913467ab6b9d4baf8f8730121d59bc2f015ec04ce02308a8642ee72aae5f4386d5cdce SHA512 2dcfd9f5759761acb811e99f033d06ac57db2bbd7f9c8980fbf865ac864c815f769bd9e635ff4eafba8b1066918fa729ac4b0da5df605b9dae5a9c428d7c2710
diff --git a/dev-haskell/readargs/metadata.xml b/dev-haskell/readargs/metadata.xml
deleted file mode 100644
index f863232f251c..000000000000
--- a/dev-haskell/readargs/metadata.xml
+++ /dev/null
@@ -1,74 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
- ReadArgs provides the @readArgs@ IO action, which lets you tell the compiler
- to parse the command line arguments to fit the type signature you give.
-
- For example @(a :: Int, b :: String, c :: Float) &lt;- readArgs@ would
- parse the first runtime argument as an @Int@, the second as a @String@ (no
- quotes required) and the third as a @Float@.
-
- If the runtime arguments are incompatible with the type signature,
- then a simple usage statement is given of the types needed.
-
- Continuing the previous example, if it was used in a
- program named @Example@, the error message for the above
- action would be:
-
- @
- usage: Example Int String Float
- @
-
- Any type that has both @Typeable@ and @Read@ instances
- can be used. @Char@, @String@, and @Text@ are handled specially so that
- command line arguments for both do not require quotes (as their
- @Read@ instances do). A special instance is provided for @FilePath@ so
- that no constructor or quotes are required.
-
- @readArgs@ also supports optional arguments and variadic arguments.
- Optional arguments are specified using @Maybe@, and variadic arguments
- using a list. @(a :: Int, b :: Maybe String, c :: [Float]) &lt;- readArgs@
- would successfully parse any of the following sets of command line arguments:
-
- @
- Example 1
- Example 1 2 3 4
- Example 1 foo
- Example 1 foo 2 3 4
- @
-
- But not
-
- @
- Example
- Example foo
- Example 1.0
- @
-
- Usage statements for optional and variadic arguments use command-line
- parlance:
-
- @
- usage: Example Int [String] [Float..]
- @
-
- Note that both optional and variadic parsers are greedy by default
- (so @Example 1 2 3 4@ was parsed as @(1, "2", [3.0,4.0])@. They
- may both be made non-greedy through use of the @NonGreedy@ constructor:
-
- @
- ( a :: Int
- , NonGreedy b :: NonGreedy Maybe String
- , NonGreedy c :: NonGreedy [] Float
- ) &lt;- readArgs
- @
- </longdescription>
- <upstream>
- <remote-id type="github">rampion/ReadArgs</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-haskell/readargs/readargs-1.2.2.ebuild b/dev-haskell/readargs/readargs-1.2.2.ebuild
deleted file mode 100644
index 7973976779b2..000000000000
--- a/dev-haskell/readargs/readargs-1.2.2.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.4.4.9999
-
-CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-MY_PN="ReadArgs"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Simple command line argument parsing"
-HOMEPAGE="https://github.com/rampion/ReadArgs"
-SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=dev-haskell/system-filepath-0.4.7:=[profile?] <dev-haskell/system-filepath-0.5:=[profile?]
- >=dev-haskell/text-0.11.1.13:=[profile?] <dev-haskell/text-12:=[profile?]
- >=dev-lang/ghc-7.4.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.8
- test? ( >=dev-haskell/hspec-1.3 )
-"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- cabal_chdeps \
- 'hspec >= 1.3 && < 2.1' 'hspec >= 1.3'
-}
diff --git a/dev-haskell/readargs/readargs-1.2.3.ebuild b/dev-haskell/readargs/readargs-1.2.3.ebuild
deleted file mode 100644
index ea206c616eeb..000000000000
--- a/dev-haskell/readargs/readargs-1.2.3.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-# ebuild generated by hackport 0.5.1.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-MY_PN="ReadArgs"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Simple command line argument parsing"
-HOMEPAGE="https://github.com/rampion/ReadArgs"
-SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=dev-haskell/system-filepath-0.4.7:=[profile?] <dev-haskell/system-filepath-0.5:=[profile?]
- >=dev-haskell/text-0.11.1.13:=[profile?] <dev-haskell/text-12:=[profile?]
- >=dev-lang/ghc-7.4.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.8
- test? ( >=dev-haskell/hspec-1.3 <dev-haskell/hspec-3 )
-"
-
-S="${WORKDIR}/${MY_P}"