summaryrefslogtreecommitdiff
path: root/dev-haskell/quickcheck/quickcheck-2.9.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:19:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-14 23:22:23 +0100
commit4b19be30aa626b327c885dae62c559ec0e9fb935 (patch)
tree76e74807bc479502e13866b581b6bf86734ec634 /dev-haskell/quickcheck/quickcheck-2.9.2.ebuild
parent30d6f67c98d149508509d5e86f176d558793acc0 (diff)
gentoo resync : 13.10.2019
Diffstat (limited to 'dev-haskell/quickcheck/quickcheck-2.9.2.ebuild')
-rw-r--r--dev-haskell/quickcheck/quickcheck-2.9.2.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-haskell/quickcheck/quickcheck-2.9.2.ebuild b/dev-haskell/quickcheck/quickcheck-2.9.2.ebuild
index 87803b71b443..d55efeea0daf 100644
--- a/dev-haskell/quickcheck/quickcheck-2.9.2.ebuild
+++ b/dev-haskell/quickcheck/quickcheck-2.9.2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
# ebuild generated by hackport 0.5.9999
-#hackport: flags: +base4,-base3,templatehaskell:template_haskell
+#hackport: flags: +base4,-base3,templatehaskell:template-haskell
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
@@ -18,8 +18,8 @@ SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="2/${PV}"
-KEYWORDS="amd64 x86 ~x86-fbsd ~amd64-linux"
-IUSE="+template_haskell"
+KEYWORDS="amd64 x86 ~amd64-linux"
+IUSE="+template-haskell"
RESTRICT=test # to avoid test circular depends
@@ -31,7 +31,7 @@ RDEPEND=">=dev-haskell/nats-1:=[profile?]
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.18.1.3
- test? ( template_haskell? ( >=dev-haskell/test-framework-0.4 <dev-haskell/test-framework-0.9 ) )
+ test? ( template-haskell? ( >=dev-haskell/test-framework-0.4 <dev-haskell/test-framework-0.9 ) )
"
S="${WORKDIR}/${MY_P}"
@@ -40,5 +40,5 @@ src_configure() {
haskell-cabal_src_configure \
--flag=-base3 \
--flag=base4 \
- $(cabal_flag template_haskell templatehaskell)
+ $(cabal_flag template-haskell templatehaskell)
}