summaryrefslogtreecommitdiff
path: root/dev-haskell/quickcheck/quickcheck-2.7.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/quickcheck/quickcheck-2.7.6.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/quickcheck/quickcheck-2.7.6.ebuild')
-rw-r--r--dev-haskell/quickcheck/quickcheck-2.7.6.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-haskell/quickcheck/quickcheck-2.7.6.ebuild b/dev-haskell/quickcheck/quickcheck-2.7.6.ebuild
new file mode 100644
index 000000000000..0d9bfb69fc61
--- /dev/null
+++ b/dev-haskell/quickcheck/quickcheck-2.7.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+#hackport: flags: +base4,-base3,templatehaskell:template_haskell
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+MY_PN="QuickCheck"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Automatic testing of Haskell programs"
+HOMEPAGE="https://github.com/nick8325/quickcheck"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux"
+IUSE="+template_haskell"
+
+RDEPEND="dev-haskell/random:=[profile?]
+ >=dev-haskell/tf-random-0.4:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/test-framework-0.4 <dev-haskell/test-framework-0.9 )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-base3 \
+ --flag=base4 \
+ $(cabal_flag template_haskell templatehaskell)
+}