summaryrefslogtreecommitdiff
path: root/dev-haskell/quickcheck/quickcheck-2.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-haskell/quickcheck/quickcheck-2.6.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-haskell/quickcheck/quickcheck-2.6.ebuild')
-rw-r--r--dev-haskell/quickcheck/quickcheck-2.6.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-haskell/quickcheck/quickcheck-2.6.ebuild b/dev-haskell/quickcheck/quickcheck-2.6.ebuild
new file mode 100644
index 000000000000..e0d69e26f45a
--- /dev/null
+++ b/dev-haskell/quickcheck/quickcheck-2.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="QuickCheck"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Automatic testing of Haskell programs"
+HOMEPAGE="http://code.haskell.org/QuickCheck"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2/${PV}"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux"
+IUSE="+template_haskell"
+
+RDEPEND="dev-haskell/extensible-exceptions:=[profile?]
+ dev-haskell/random:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag template_haskell templatehaskell)
+}