summaryrefslogtreecommitdiff
path: root/dev-haskell/quickcheck-instances/quickcheck-instances-0.3.22.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-haskell/quickcheck-instances/quickcheck-instances-0.3.22.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-haskell/quickcheck-instances/quickcheck-instances-0.3.22.ebuild')
-rw-r--r--dev-haskell/quickcheck-instances/quickcheck-instances-0.3.22.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-haskell/quickcheck-instances/quickcheck-instances-0.3.22.ebuild b/dev-haskell/quickcheck-instances/quickcheck-instances-0.3.22.ebuild
new file mode 100644
index 000000000000..57aaeb77b538
--- /dev/null
+++ b/dev-haskell/quickcheck-instances/quickcheck-instances-0.3.22.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Common quickcheck instances"
+HOMEPAGE="https://github.com/phadej/qc-instances"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/base-compat-0.9.3:=[profile?]
+ >=dev-haskell/case-insensitive-1.2.0.4:=[profile?] <dev-haskell/case-insensitive-1.3:=[profile?]
+ >=dev-haskell/hashable-1.2.5.0:=[profile?] <dev-haskell/hashable-1.4:=[profile?]
+ >=dev-haskell/nats-1:=[profile?] <dev-haskell/nats-1.2:=[profile?]
+ >=dev-haskell/old-time-1.1.0.0:=[profile?] <dev-haskell/old-time-1.2:=[profile?]
+ >=dev-haskell/quickcheck-2.13.2:2=[profile?] <dev-haskell/quickcheck-2.14:2=[profile?]
+ >=dev-haskell/scientific-0.2.0.0:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
+ >=dev-haskell/semigroups-0.18.5:=[profile?] <dev-haskell/semigroups-0.20:=[profile?]
+ >=dev-haskell/splitmix-0.0.2:=[profile?] <dev-haskell/splitmix-0.1:=[profile?]
+ >=dev-haskell/tagged-0.8.5:=[profile?] <dev-haskell/tagged-0.9:=[profile?]
+ >=dev-haskell/text-1.0.0.0:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/time-compat-1.9.2.2:=[profile?] <dev-haskell/time-compat-1.10:=[profile?]
+ >=dev-haskell/transformers-compat-0.5:=[profile?] <dev-haskell/transformers-compat-0.7:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.2.0:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/uuid-types-1.0.3:=[profile?] <dev-haskell/uuid-types-1.1:=[profile?]
+ >=dev-haskell/vector-0.9:=[profile?] <dev-haskell/vector-0.13:=[profile?]
+ >=dev-haskell/void-0.7.2:=[profile?] <dev-haskell/void-0.8:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'base >=4.5 && <4.13' 'base >=4.5' \
+ 'base-compat >=0.9.3 && <0.11' 'base-compat >=0.9.3'
+}