summaryrefslogtreecommitdiff
path: root/dev-haskell/quickcheck-instances/quickcheck-instances-0.3.12-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-haskell/quickcheck-instances/quickcheck-instances-0.3.12-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-haskell/quickcheck-instances/quickcheck-instances-0.3.12-r1.ebuild')
-rw-r--r--dev-haskell/quickcheck-instances/quickcheck-instances-0.3.12-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/quickcheck-instances/quickcheck-instances-0.3.12-r1.ebuild b/dev-haskell/quickcheck-instances/quickcheck-instances-0.3.12-r1.ebuild
new file mode 100644
index 000000000000..e490930beedb
--- /dev/null
+++ b/dev-haskell/quickcheck-instances/quickcheck-instances-0.3.12-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Common quickcheck instances"
+HOMEPAGE="https://github.com/aslatter/qc-instances"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/hashable-1.1.2.3:=[profile?] <dev-haskell/hashable-1.3:=[profile?]
+ >=dev-haskell/old-time-1.0:=[profile?] <dev-haskell/old-time-1.2:=[profile?]
+ >=dev-haskell/quickcheck-2.1:2=[profile?]
+ >=dev-haskell/scientific-0.2:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
+ >=dev-haskell/text-0.7:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.1:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/vector-0.9:=[profile?] <dev-haskell/vector-0.12:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'QuickCheck >= 2.1 && < 2.9' 'QuickCheck >= 2.1'
+}