summaryrefslogtreecommitdiff
path: root/dev-haskell/pwstore-fast
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-haskell/pwstore-fast
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-haskell/pwstore-fast')
-rw-r--r--dev-haskell/pwstore-fast/Manifest4
-rw-r--r--dev-haskell/pwstore-fast/metadata.xml13
-rw-r--r--dev-haskell/pwstore-fast/pwstore-fast-2.4.4.ebuild7
3 files changed, 5 insertions, 19 deletions
diff --git a/dev-haskell/pwstore-fast/Manifest b/dev-haskell/pwstore-fast/Manifest
index 9e84025ac8e1..6a4788fecc5d 100644
--- a/dev-haskell/pwstore-fast/Manifest
+++ b/dev-haskell/pwstore-fast/Manifest
@@ -1,3 +1,3 @@
DIST pwstore-fast-2.4.4.tar.gz 8901 BLAKE2B 27e26a1c934264ea18797c6e5c9bd91dacd00e02ee67a0ec7e39dd51fa10c37b9999b1698800ffdfc7954aced9f3d076a94cc5d423b022af5d0168862e81415a SHA512 707381466d22b9d4cb45884be1df0c1567b11c1ed698b19c968f72b0b68898aa384df5f7c12fb5944ebc2bbcf28fd22c4cefed696d37503ac8b39ab9cdebb0f1
-EBUILD pwstore-fast-2.4.4.ebuild 729 BLAKE2B 39974d2330045874a590635a5f48c96fd0f1cd49bd52982a927fd6cb9973aa2519dc02f705f8859796ed0b7f088559d6f74ad861409d2526ab6a4aa65c7b9250 SHA512 7d82b6b410a5f9836ff5dbb2d89dbe2396e89e352b73fd587040fe82c5420208663996a2453c3ca59fddba5b075f42a7079835004e62e86002663342f3e74a9a
-MISC metadata.xml 761 BLAKE2B e0ae65cafc745bda3d084a2735eda2dfdf5f8ce15d58d97e959c630cb3b4d5cee2117413146838385ac569360fb14e4eb78cbbd720b1da0740ec97f30a6e0c79 SHA512 634067afe08b6634214fb6207f62a30899493a0b0362b92388b4280aaa0d359df70b01145dbc4c15059d7d808409549b56b050385c2eb953fc2341546c3283eb
+EBUILD pwstore-fast-2.4.4.ebuild 691 BLAKE2B 9c7b891813ce512bc0842fb1b196bbe0f074ebacb3f43eb1fa96174477296161acfbc9f5211284cfd07fc53b196356e0c3e8596c29733d6307abdb5d4a88f734 SHA512 dc686866ff2f68c79e84cf7162748cec503b79165538e8deec895c5b2ab911f5000186c642802a11b61ee3ab3d4bbc0f97898e2ec44b936b2f699f7bf2fe17df
+MISC metadata.xml 249 BLAKE2B 84b809c265ff2a09d1f06c66d4797652ff4c64205d94323e07333ae0fbddcfb8c58d0176a8cc52bd37e9353371d987b9b473b9747cb082e1c2871ed80fcfa144 SHA512 ce055b41ff1c10209e88579fe21ce16550be7e9b21f87724564f06430aa6f478974f186a10c8ff7e92398f534c09109aeed57eae1c6d2b56b5c99ebfb64a0015
diff --git a/dev-haskell/pwstore-fast/metadata.xml b/dev-haskell/pwstore-fast/metadata.xml
index cdbf6fd8bacc..b7878815d80d 100644
--- a/dev-haskell/pwstore-fast/metadata.xml
+++ b/dev-haskell/pwstore-fast/metadata.xml
@@ -5,17 +5,4 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- To store passwords securely, they should be salted,
- then hashed with a slow hash function. This library
- uses PBKDF1-SHA256, and handles all the details.
- It uses the cryptohash package for speed; if you need
- a pure Haskell library, pwstore-purehaskell has the
- exact same API, but uses only pure Haskell. It is
- about 25 times slower than this package, but still
- quite usable.
- </longdescription>
- <upstream>
- <remote-id type="github">PeterScott/pwstore</remote-id>
- </upstream>
</pkgmetadata>
diff --git a/dev-haskell/pwstore-fast/pwstore-fast-2.4.4.ebuild b/dev-haskell/pwstore-fast/pwstore-fast-2.4.4.ebuild
index c285f1a28c89..1303a14bfc7d 100644
--- a/dev-haskell/pwstore-fast/pwstore-fast-2.4.4.ebuild
+++ b/dev-haskell/pwstore-fast/pwstore-fast-2.4.4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-# ebuild generated by hackport 0.4.4.9999
+# ebuild generated by hackport 0.6.6.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
@@ -18,7 +18,6 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND=">=dev-haskell/base64-bytestring-0.1:=[profile?]
- >=dev-haskell/binary-0.5:=[profile?]
>=dev-haskell/byteable-0.1:=[profile?]
>=dev-haskell/cryptohash-0.6:=[profile?]
>=dev-haskell/random-1:=[profile?]