summaryrefslogtreecommitdiff
path: root/dev-haskell/pwstore-fast
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/pwstore-fast
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/pwstore-fast')
-rw-r--r--dev-haskell/pwstore-fast/Manifest3
-rw-r--r--dev-haskell/pwstore-fast/metadata.xml21
-rw-r--r--dev-haskell/pwstore-fast/pwstore-fast-2.4.4.ebuild29
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-haskell/pwstore-fast/Manifest b/dev-haskell/pwstore-fast/Manifest
new file mode 100644
index 000000000000..86638db6c5aa
--- /dev/null
+++ b/dev-haskell/pwstore-fast/Manifest
@@ -0,0 +1,3 @@
+DIST pwstore-fast-2.4.4.tar.gz 8901 BLAKE2B 27e26a1c934264ea18797c6e5c9bd91dacd00e02ee67a0ec7e39dd51fa10c37b9999b1698800ffdfc7954aced9f3d076a94cc5d423b022af5d0168862e81415a SHA512 707381466d22b9d4cb45884be1df0c1567b11c1ed698b19c968f72b0b68898aa384df5f7c12fb5944ebc2bbcf28fd22c4cefed696d37503ac8b39ab9cdebb0f1
+EBUILD pwstore-fast-2.4.4.ebuild 737 BLAKE2B b7bce11efd4286eb2773ef1a581776b372f0e2119e4ac289779e72b17d19835cd9cb6400646d197fffde2e89d29eda14ee5cb934f6aab148805ad32de8548063 SHA512 ff2d50466512c7b691deb8b383fc6ec2b75ac1079d8b86d4b49407ac37733b410c37ca657a3dc1b41fa635c2fbb44ca9fe08128dc624018d7bbdc801abaf5cce
+MISC metadata.xml 761 BLAKE2B e0ae65cafc745bda3d084a2735eda2dfdf5f8ce15d58d97e959c630cb3b4d5cee2117413146838385ac569360fb14e4eb78cbbd720b1da0740ec97f30a6e0c79 SHA512 634067afe08b6634214fb6207f62a30899493a0b0362b92388b4280aaa0d359df70b01145dbc4c15059d7d808409549b56b050385c2eb953fc2341546c3283eb
diff --git a/dev-haskell/pwstore-fast/metadata.xml b/dev-haskell/pwstore-fast/metadata.xml
new file mode 100644
index 000000000000..cdbf6fd8bacc
--- /dev/null
+++ b/dev-haskell/pwstore-fast/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ To store passwords securely, they should be salted,
+ then hashed with a slow hash function. This library
+ uses PBKDF1-SHA256, and handles all the details.
+ It uses the cryptohash package for speed; if you need
+ a pure Haskell library, pwstore-purehaskell has the
+ exact same API, but uses only pure Haskell. It is
+ about 25 times slower than this package, but still
+ quite usable.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">PeterScott/pwstore</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/pwstore-fast/pwstore-fast-2.4.4.ebuild b/dev-haskell/pwstore-fast/pwstore-fast-2.4.4.ebuild
new file mode 100644
index 000000000000..fb207376e687
--- /dev/null
+++ b/dev-haskell/pwstore-fast/pwstore-fast-2.4.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Secure password storage"
+HOMEPAGE="https://github.com/PeterScott/pwstore"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/base64-bytestring-0.1:=[profile?]
+ >=dev-haskell/binary-0.5:=[profile?]
+ >=dev-haskell/byteable-0.1:=[profile?]
+ >=dev-haskell/cryptohash-0.6:=[profile?]
+ >=dev-haskell/random-1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"