summaryrefslogtreecommitdiff
path: root/dev-haskell/punycode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/punycode
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/punycode')
-rw-r--r--dev-haskell/punycode/Manifest3
-rw-r--r--dev-haskell/punycode/metadata.xml14
-rw-r--r--dev-haskell/punycode/punycode-2.0.ebuild31
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-haskell/punycode/Manifest b/dev-haskell/punycode/Manifest
new file mode 100644
index 000000000000..9871b43d0457
--- /dev/null
+++ b/dev-haskell/punycode/Manifest
@@ -0,0 +1,3 @@
+DIST punycode-2.0.tar.gz 6243 BLAKE2B b6a0b5123ea3dbd8b8c28ea56b4cf7425962011224549ece1c3c2c5b6a951e7e8c76c46f33a548f43ec650a42ef98f373769f623b4094ab6e222f5e2b91ce621 SHA512 106ee29667582f0341b993b8fd888046e70aff02bf9a31fb883488ed0f1fe346ae6dacd60ceacf088c056b50cb99d633322f066be391585af9c37fd8e5e4ff44
+EBUILD punycode-2.0.ebuild 792 BLAKE2B e563db2b1ba1044f35fd7f57a747f4d407d48030a01459b94901177f0ad4bcd6e11ac7e41a08fcf4240a777ff320a474b4ec0dbd8bf8bd933fa77819b9d97842 SHA512 e0da9722ae6ced37aaa46e32ef5dcdead94195561718c30d68975573eaf05383442fd6a71915c1ed6ac503600c80f50f4939fc81c58855c6fb4183cb9e8dc2c5
+MISC metadata.xml 640 BLAKE2B 471d4516143eb307d40d70cc7675bc6021ead59615a2f27dadad6daa7214225dc74ec87d192779bef70f74aa83da849b6a66faa4bb8185dd5935deae8fcaf4e9 SHA512 8b6a12f34e2649b090b1effb5acdf18f600132a879393560d0d99b9f887047efb2804bb36a244da51def9c3e662de5604f1bbe93d896bcc3c0ffb376edaaa149
diff --git a/dev-haskell/punycode/metadata.xml b/dev-haskell/punycode/metadata.xml
new file mode 100644
index 000000000000..73a13817ca69
--- /dev/null
+++ b/dev-haskell/punycode/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Encode unicode strings to ascii forms according to RFC 3492. It is written in pure Haskell, as opposed to gnuidn's Data.Text.IDN.Punycode. Please note that Data.Encoding.BootString from the 'encoding' package also contains an implementation of the Punycode algorithm.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">litherum/punycode</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/punycode/punycode-2.0.ebuild b/dev-haskell/punycode/punycode-2.0.ebuild
new file mode 100644
index 000000000000..6c7cdca0629d
--- /dev/null
+++ b/dev-haskell/punycode/punycode-2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Encode unicode strings to ascii forms according to RFC 3492"
+HOMEPAGE="https://github.com/litherum/punycode"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RESTRICT=test # runs slow, finds error
+
+RDEPEND="dev-haskell/cereal:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/text:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/encoding
+ dev-haskell/hunit
+ dev-haskell/quickcheck
+ )"