summaryrefslogtreecommitdiff
path: root/dev-haskell/psqueue
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/psqueue
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/psqueue')
-rw-r--r--dev-haskell/psqueue/Manifest3
-rw-r--r--dev-haskell/psqueue/metadata.xml17
-rw-r--r--dev-haskell/psqueue/psqueue-1.1-r1.ebuild29
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-haskell/psqueue/Manifest b/dev-haskell/psqueue/Manifest
new file mode 100644
index 000000000000..b2554cb6438c
--- /dev/null
+++ b/dev-haskell/psqueue/Manifest
@@ -0,0 +1,3 @@
+DIST PSQueue-1.1.tar.gz 6280 BLAKE2B 5810404fa4cb93814987215b8ab4177540647ddb4e2d8678d53529e2539edb441fcc25cff26e9037ca6fb37c709b9dfd4e34a19d0d716e10270849ea297fda81 SHA512 34fbd599b7fc47aef8952db79c848f4b50716d2d900b1d8274733ad4c7382d41a0407159e89af9828355c618412c626e4384f2e7461396b51cf866d9b8cfdb0d
+EBUILD psqueue-1.1-r1.ebuild 602 BLAKE2B e4017909cd44cff970620247b716313f89215d2625f71ca340e3384111267c74bbc64290e58c19eda5019ed9bd9c22b85ff92b7894409508bb43f3f10327c674 SHA512 9d717926e0219b292654589d29c9ca08403ccb47f4245109403c83f46563ba0da8bd8f8dcf0d2929ecf53a965eaae327302b3f4b803232c8021653e9f529dad1
+MISC metadata.xml 691 BLAKE2B 78baa032bd5a89295ca70ddf36cf475c41f60a265f714814dcb53c066e69eec6ab8f02f5776f26af6c0f96d5419dbe3244027a87ccf1689da7a015fa458a3f47 SHA512 98fedd95dda5a745ff464cff72dde0571a7a2156f8c9cde1124e3789b71059ac117d955d3891a9356cd78ff4cd2b9c5c9712ed7668637612e935062a40735fb9
diff --git a/dev-haskell/psqueue/metadata.xml b/dev-haskell/psqueue/metadata.xml
new file mode 100644
index 000000000000..63915bdba3bc
--- /dev/null
+++ b/dev-haskell/psqueue/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ A /priority search queue/ efficiently supports the
+ opperations of both a search tree and a priority queue. A
+ 'Binding' is a product of a key and a priority. Bindings
+ can be inserted, deleted, modified and queried in
+ logarithmic time, and the binding with the least priority
+ can be retrieved in constant time. A queue can be built
+ from a list of bindings, sorted by keys, in linear time.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/psqueue/psqueue-1.1-r1.ebuild b/dev-haskell/psqueue/psqueue-1.1-r1.ebuild
new file mode 100644
index 000000000000..b71627525966
--- /dev/null
+++ b/dev-haskell/psqueue/psqueue-1.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="PSQueue"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Priority Search Queue"
+HOMEPAGE="http://hackage.haskell.org/package/PSQueue"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2
+"
+
+S="${WORKDIR}/${MY_P}"