summaryrefslogtreecommitdiff
path: root/dev-haskell/polyparse
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/polyparse
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/polyparse')
-rw-r--r--dev-haskell/polyparse/Manifest5
-rw-r--r--dev-haskell/polyparse/metadata.xml16
-rw-r--r--dev-haskell/polyparse/polyparse-1.11.ebuild25
-rw-r--r--dev-haskell/polyparse/polyparse-1.9.ebuild23
4 files changed, 69 insertions, 0 deletions
diff --git a/dev-haskell/polyparse/Manifest b/dev-haskell/polyparse/Manifest
new file mode 100644
index 000000000000..8924a0e6ffd3
--- /dev/null
+++ b/dev-haskell/polyparse/Manifest
@@ -0,0 +1,5 @@
+DIST polyparse-1.11.tar.gz 22978 BLAKE2B 22154655fb090234223189f9f25e871c73f478ee3681313654d737930d594c9a378fa1d259ff4cdbe93d2df5a8ac79104ee12b9efed7e9fdf1caf6ad269ab988 SHA512 b2cecc633596caaa2b8a00ceb16f141cd69de9ec697ce53cd827a17c82cac70ffaf10bc1d8669156ed4d28589b11ac56820b5c02905c8a6bdcae65112126fa5e
+DIST polyparse-1.9.tar.gz 22256 BLAKE2B 01f2280db5d966d86450b4a3ae352e1ba911c1d7b116e6e94cd182c6d49c4b43e6d52f264097b4e8c87867bd535140b18c04a445ee9ab60f9296e1a15bcdeb0f SHA512 80f7cc269c7082d256aa273ce668a8fd9f58b4827fa69e390d749a622d667d5c01b7ede3719d52408d3efa35de66928a3fa659f3798826a2d53222d8a8d9d7e6
+EBUILD polyparse-1.11.ebuild 632 BLAKE2B 5c1ae3477b3f87dcecccf200cf0eeebc0394cbfe3d0f7e4837875828720a5d3e38b84c56cbb14023762d4a2d84911a26edd4c79f51ca3dd73af8b4f3ebd615d1 SHA512 642dcec362c56822d2cb47a0d4ef5f4611c5459434ca7a5ca0dcd7f77b838a1e1ba10e5b3599a16be67d4e25cb6bbe56e10b6199e056447771752700b66dba97
+EBUILD polyparse-1.9.ebuild 626 BLAKE2B 04c98538575bd0a1112c125f96bdcc7d5f89d76f5fe8287642a2c74e6dc746c0aa142a8744141472e2030dc8786f48a1a6df1d38965f3d22edd0b2cb3e9c0713 SHA512 82e2221975f8c460d21183ebb2efe04f0bf2b2b8bb931a5aaaa9b043a92b7b74ff598ab0cd1a857674fedd76a958765566e7e8de075ab2eee1815125d9e72a5f
+MISC metadata.xml 648 BLAKE2B ec7679bb8dec7212a08a306a1b57b796aa6037f642cbedc234a42da09de700a7a7faff3219e9d8019ff6ae0641260e07bbdc7cd78352940f195bc300f6e2bf6b SHA512 ec7413b7f4fbc51776411fef7a21be4bfdbfbb52640d3b21467177b09903c0cdf860c201c7450e9f2dbcd87c918676fd69969319afafc29e75d0f989b4e7963d
diff --git a/dev-haskell/polyparse/metadata.xml b/dev-haskell/polyparse/metadata.xml
new file mode 100644
index 000000000000..c662f542cdfb
--- /dev/null
+++ b/dev-haskell/polyparse/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ A variety of alternative parser combinator libraries, including
+ the original HuttonMeijer set. The Poly sets have features like
+ good error reporting, arbitrary token type, running state, lazy
+ parsing, and so on. Finally, Text.Parse is a proposed
+ replacement for the standard Read class, for better
+ deserialisation of Haskell values from Strings.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/polyparse/polyparse-1.11.ebuild b/dev-haskell/polyparse/polyparse-1.11.ebuild
new file mode 100644
index 000000000000..d2762f3798da
--- /dev/null
+++ b/dev-haskell/polyparse/polyparse-1.11.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A variety of alternative parser combinator libraries"
+HOMEPAGE="http://code.haskell.org/~malcolm/polyparse/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE=""
+
+RDEPEND="dev-haskell/text:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2
+"
diff --git a/dev-haskell/polyparse/polyparse-1.9.ebuild b/dev-haskell/polyparse/polyparse-1.9.ebuild
new file mode 100644
index 000000000000..cf6cd6b21602
--- /dev/null
+++ b/dev-haskell/polyparse/polyparse-1.9.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A variety of alternative parser combinator libraries"
+HOMEPAGE="http://code.haskell.org/~malcolm/polyparse/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE=""
+
+RDEPEND="dev-haskell/text:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"