summaryrefslogtreecommitdiff
path: root/dev-haskell/pipes
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-22 02:42:13 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-22 02:42:13 +0100
commite7f37e03b952768321c8c943a80eff4152ea7bbd (patch)
tree355a9efb62297418cdadbc424b09dbafc54257e5 /dev-haskell/pipes
parent2518522472e5de9c52c78dc0246475fe0ae3cc05 (diff)
gentoo auto-resync : 22:08:2022 - 02:42:13
Diffstat (limited to 'dev-haskell/pipes')
-rw-r--r--dev-haskell/pipes/Manifest3
-rw-r--r--dev-haskell/pipes/metadata.xml35
-rw-r--r--dev-haskell/pipes/pipes-4.3.14.ebuild33
3 files changed, 0 insertions, 71 deletions
diff --git a/dev-haskell/pipes/Manifest b/dev-haskell/pipes/Manifest
deleted file mode 100644
index 5f3128223fba..000000000000
--- a/dev-haskell/pipes/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST pipes-4.3.14.tar.gz 42576 BLAKE2B 2d14d39f615965eb27d8c2a1bc92bc6e306bf5604760939121de74bd7752825f646e0f55e3c044f31b937357e97a2a1633f7fea6434b1a12522618d77df08559 SHA512 4dac195772876c62d187a123c99ec2c624ce9f5b4c8ea8de9621d01c4eaaaf99a2f856a2c9faf94ec35c531df29f0e82aa9015ad8dd4eb2b2d7478a0da4bacf5
-EBUILD pipes-4.3.14.ebuild 1218 BLAKE2B e04ec0d68b34b7fc42687f574c5fd1a09edb431d61916a570de0ecc12124cd815e0fab398df85939c9a8328df04e14922460fdd955503acf5a171a5df26ebf8d SHA512 457026be04a27dd7e5947564f6ec436db4511b6301762f9b9a9c9cb7e6e80efe27d48f7438620002035d8de469b9cfd82ac97ae49b2c25f650c7cf6ca2278ded
-MISC metadata.xml 1138 BLAKE2B 7856656f3892097c61a6ae6b233cf295bba3c079d904f92073a9e3a8188be28b19a8472f78326aa86105cf9cda6bf13d1b6110935d4e9117ad904feb1f2e0f6a SHA512 5da1ee34b6925f358a3e474b122cf33c6e51b1608fb182cda21a68f66f04416ba819e458973a626e17ce8e0e0d0d876379f8b25aa2e016d43c9fb22b6f255237
diff --git a/dev-haskell/pipes/metadata.xml b/dev-haskell/pipes/metadata.xml
deleted file mode 100644
index d5894163855e..000000000000
--- a/dev-haskell/pipes/metadata.xml
+++ /dev/null
@@ -1,35 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
- \"Coroutines done right\". This library generalizes iteratees and coroutines
- simply and elegantly.
-
- Advantages over traditional iteratee\/coroutine implementations:
-
- * /Concise API/: Use three simple commands: ('&gt;-&gt;'), 'request', and 'respond'
-
- * /Bidirectionality/: Implement duplex channels
-
- * /Blazing fast/: Implementation tuned for speed
-
- * /Elegant semantics/: Use practical category theory
-
- * /Extension Framework/: Mix and match extensions and create your own
-
- * /ListT/: Correct implementation of ListT that interconverts with pipes
-
- * /Lightweight Dependency/: @pipes@ depends only on @transformers@ and
- @mmorph@ and compiles rapidly
-
- * /Extensive Documentation/: Second to none!
-
- Import "Control.Proxy" to use the library.
-
- Read "Control.Proxy.Tutorial" for an extensive tutorial.
- </longdescription>
-</pkgmetadata>
diff --git a/dev-haskell/pipes/pipes-4.3.14.ebuild b/dev-haskell/pipes/pipes-4.3.14.ebuild
deleted file mode 100644
index 4b0d2f65d5a9..000000000000
--- a/dev-haskell/pipes/pipes-4.3.14.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.6.6
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="Compositional pipelines"
-HOMEPAGE="https://hackage.haskell.org/package/pipes"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=dev-haskell/exceptions-0.4:=[profile?] <dev-haskell/exceptions-0.11:=[profile?]
- >=dev-haskell/fail-4.9:=[profile?] <dev-haskell/fail-4.10:=[profile?]
- >=dev-haskell/mmorph-1.0.4:=[profile?] <dev-haskell/mmorph-1.2:=[profile?]
- >=dev-haskell/mtl-2.2.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
- >=dev-haskell/semigroups-0.17:=[profile?] <dev-haskell/semigroups-0.20:=[profile?]
- >=dev-haskell/void-0.4:=[profile?] <dev-haskell/void-0.8:=[profile?]
- >=dev-lang/ghc-7.10.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.22.2.0
- test? ( >=dev-haskell/quickcheck-2.4 <dev-haskell/quickcheck-3
- >=dev-haskell/test-framework-0.4 <dev-haskell/test-framework-1
- >=dev-haskell/test-framework-quickcheck2-0.2.0 <dev-haskell/test-framework-quickcheck2-0.4 )
-"