summaryrefslogtreecommitdiff
path: root/dev-haskell/pcre-light/pcre-light-0.4.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-haskell/pcre-light/pcre-light-0.4.1.0.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-haskell/pcre-light/pcre-light-0.4.1.0.ebuild')
-rw-r--r--dev-haskell/pcre-light/pcre-light-0.4.1.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-haskell/pcre-light/pcre-light-0.4.1.0.ebuild b/dev-haskell/pcre-light/pcre-light-0.4.1.0.ebuild
new file mode 100644
index 000000000000..0f291f743a7c
--- /dev/null
+++ b/dev-haskell/pcre-light/pcre-light-0.4.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.1
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Portable regex library for Perl 5 compatible regular expressions"
+HOMEPAGE="https://github.com/Daniel-Diaz/pcre-light"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+#IUSE="use-pkg-config"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+ dev-libs/libpcre
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0
+ virtual/pkgconfig
+ test? ( >=dev-haskell/hunit-1.2.5.2
+ >=dev-haskell/mtl-2.1.3.2 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=use-pkg-config \
+ --flag=-old_base
+}