summaryrefslogtreecommitdiff
path: root/dev-haskell/path-io
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/path-io
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/path-io')
-rw-r--r--dev-haskell/path-io/Manifest3
-rw-r--r--dev-haskell/path-io/metadata.xml11
-rw-r--r--dev-haskell/path-io/path-io-1.2.2.ebuild42
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-haskell/path-io/Manifest b/dev-haskell/path-io/Manifest
new file mode 100644
index 000000000000..0cd2258fb300
--- /dev/null
+++ b/dev-haskell/path-io/Manifest
@@ -0,0 +1,3 @@
+DIST path-io-1.2.2.tar.gz 17818 BLAKE2B 5a4a39ff0282e2d2294b8392af954fd0bba036ff223b95dca1951b202b6a4be14373bf439b826d4fb868e4378f9beb45488a77955a6c8e10bd5af70ea72fb57d SHA512 910af5fd9345daa815235027992e6ab4af3784da7afa314644abaf8acb5bee59f3f1444449ce55e88961c86031cf4537c855e13ba2e777348d9fe4c0104fb6d1
+EBUILD path-io-1.2.2.ebuild 1094 BLAKE2B 59dd6b3621724800680669b3f1f4f8bc3dd37a9c719097aa68b4e0c4c7eacf42fee6625266920abe22a46c1f0c8845741d3ae4c304c1d8c9f5ed9a7daad8ebab SHA512 6a2a8420425e536b022ee705cc9b11b5aa372068b279f7c2a902b2815980003981e6250f93c1febf3f5c3684fbc7871b2a5dbd6426973ad5ea317fa1b5787043
+MISC metadata.xml 340 BLAKE2B dd3091702c88dbfc3d33f22fc20d8c10b506d3efceb9c8b6277c46a11af951de5eba045cf56a73aa2ee88a0010749e3aac8c9a11ca08174f9fdff4caa107a0fe SHA512 6d5348e164095958d860fb532fc3354d8edc244dd1f0b9b90eee725659f5616c54c3e841489c4752aa470e6531d04ae212898a02652876eaf2f18639c17b1827
diff --git a/dev-haskell/path-io/metadata.xml b/dev-haskell/path-io/metadata.xml
new file mode 100644
index 000000000000..f7fb2720334b
--- /dev/null
+++ b/dev-haskell/path-io/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Interface to directory package for users of path.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/path-io/path-io-1.2.2.ebuild b/dev-haskell/path-io/path-io-1.2.2.ebuild
new file mode 100644
index 000000000000..54a64dff47ee
--- /dev/null
+++ b/dev-haskell/path-io/path-io-1.2.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+#hackport: flags: -dev
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Interface to 'directory' package for users of 'path'"
+HOMEPAGE="https://github.com/mrkkrp/path-io"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/exceptions-0.8:=[profile?] <dev-haskell/exceptions-0.9:=[profile?]
+ >=dev-haskell/path-0.5:=[profile?] <dev-haskell/path-0.6:=[profile?]
+ >=dev-haskell/temporary-1.1:=[profile?] <dev-haskell/temporary-1.3:=[profile?]
+ dev-haskell/unix-compat:=[profile?]
+ >=dev-lang/ghc-7.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.22.2.0
+ test? ( >=dev-haskell/hspec-2.0 <dev-haskell/hspec-3.0 )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'time >= 1.4 && < 1.7' 'time >= 1.4'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-dev
+}