summaryrefslogtreecommitdiff
path: root/dev-haskell/parsers
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-haskell/parsers
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-haskell/parsers')
-rw-r--r--dev-haskell/parsers/Manifest3
-rw-r--r--dev-haskell/parsers/metadata.xml19
-rw-r--r--dev-haskell/parsers/parsers-0.12.10.ebuild41
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-haskell/parsers/Manifest b/dev-haskell/parsers/Manifest
new file mode 100644
index 000000000000..faf5c5ec942d
--- /dev/null
+++ b/dev-haskell/parsers/Manifest
@@ -0,0 +1,3 @@
+DIST parsers-0.12.10.tar.gz 26215 BLAKE2B 35303f6f4919e07b77490f5bcbc2a45efe8fda5edf169ade7dd7cd3bd080f2d24d5470ecb47f8a6428be1176faa8d138616e8f2635f9974ed473c8a61145e8ee SHA512 99ff90de4e60be3c03c8e1e5ae7902a37424c3139ccf566ff1cbc363d176787bd60bb709ef6c56f5b446f1f1b7eca65aa5d431897a0f82a9d6f7fe77fd2ee49f
+EBUILD parsers-0.12.10.ebuild 1495 BLAKE2B 588843cabdf6475f83401d8d51362fab3aee8fc2336842d13d6d46daf0eed227ee1fd0884055c9d65765baeceb64423ecff28e1051d682ca796faaf425c478d6 SHA512 fa02af09569303b982010c73f64c5d54f7f42444ff08f6172528239a07dc88ecf1cc1b51a929a413cd1f093884593fbba50c28b117083cd184d76ff29a3fc4e9
+MISC metadata.xml 860 BLAKE2B 2578752f82eb9b0f48db65ff635446dc167def7c5a01a874609a6599e8544d407001936c0ba24ca6ebff39d549b4a52a536451a6325259b090ac159911318438 SHA512 2d4427181eadc4b5c7db4457f2b982ef893d1e30ff93c9605a1a2b28efa9ae9ea3b9832edcb7fa16062517ac2c31c8570eb22c7ff7bd90fec39c4287fdda4a24
diff --git a/dev-haskell/parsers/metadata.xml b/dev-haskell/parsers/metadata.xml
new file mode 100644
index 000000000000..0149708d6d5a
--- /dev/null
+++ b/dev-haskell/parsers/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <use>
+ <flag name="parsec">Enable the use of the `parsec` package</flag>
+ <flag name="attoparsec">Enable the use of the `attoparsec` package</flag>
+ </use>
+ <longdescription>
+ This library provides convenient combinators for working with and building parsing combinator libraries.
+
+ Given a few simple instances, e.g. for the class &#39;Text.Parser.Combinators.Parsing&#39; in &quot;Text.Parser.Combinators.Parsing&quot; you
+ get access to a large number of canned definitions. Instances exist for the parsers provided by @parsec@,
+ @attoparsec@ and base’s &quot;Text.Read&quot;.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/parsers/parsers-0.12.10.ebuild b/dev-haskell/parsers/parsers-0.12.10.ebuild
new file mode 100644
index 000000000000..a262cb26304a
--- /dev/null
+++ b/dev-haskell/parsers/parsers-0.12.10.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Parsing combinators"
+HOMEPAGE="https://github.com/ekmett/parsers/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+attoparsec +parsec"
+
+RDEPEND=">=dev-haskell/base-orphans-0.3:=[profile?] <dev-haskell/base-orphans-1:=[profile?]
+ >=dev-haskell/charset-0.3:=[profile?] <dev-haskell/charset-1:=[profile?]
+ >=dev-haskell/mtl-2.0.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/scientific-0.3:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
+ >=dev-haskell/semigroups-0.12:=[profile?] <dev-haskell/semigroups-1:=[profile?]
+ >=dev-haskell/text-0.10:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/unordered-containers-0.2:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+ attoparsec? ( >=dev-haskell/attoparsec-0.12.1.4:=[profile?] <dev-haskell/attoparsec-0.14:=[profile?] )
+ parsec? ( >=dev-haskell/parsec-3.1:=[profile?] <dev-haskell/parsec-3.2:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( dev-haskell/quickcheck
+ dev-haskell/quickcheck-instances )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag attoparsec attoparsec) \
+ $(cabal_flag parsec parsec)
+}