summaryrefslogtreecommitdiff
path: root/dev-haskell/parsec1
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /dev-haskell/parsec1
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'dev-haskell/parsec1')
-rw-r--r--dev-haskell/parsec1/Manifest3
-rw-r--r--dev-haskell/parsec1/metadata.xml34
-rw-r--r--dev-haskell/parsec1/parsec1-1.0.0.6.ebuild24
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-haskell/parsec1/Manifest b/dev-haskell/parsec1/Manifest
new file mode 100644
index 000000000000..ad1771234f10
--- /dev/null
+++ b/dev-haskell/parsec1/Manifest
@@ -0,0 +1,3 @@
+DIST parsec1-1.0.0.6.tar.gz 13871 BLAKE2B 4159797292ee8a5a64ec53c324fab116aad1c3974183c978b6e43a124e58e897b5115ff36349218b8c57fd2a69c54b592322dfa7c0cfc20761490d7f0c205d82 SHA512 1372007edd048aa5cca20f44fe70041b238c0b5aa36ed2c189124072f5d7671d3d164cbad58c8ce3f5c7bff01096fc9deec80cd21edc5475eecae12d2c4c6c38
+EBUILD parsec1-1.0.0.6.ebuild 536 BLAKE2B 41921be9cbded1ba70640f3cdd3aa1dc2fc481bee71ef4ab7ee95ccb7189f18a0f55c54e1136922cb07e3da81754186ea82ac4a373cff414381f4306055282a4 SHA512 3b9949c2b7f76986db97cc1871f17b48fa824901ee05a20479fd2c4bf8b7f1fe0b6684651c2f23f1d787983ae69c12b8566eb07163378c0c9e0ce66be85c7398
+MISC metadata.xml 1632 BLAKE2B 5c71f566acdaf288307be7022b33cca59fefb2d98e9feca1b4921c3d68e45646181afa3165ea711e84266ee9c84dc0e1895aadc4b8a37c57ab09b42bb137a9cd SHA512 a5a329aac51110347dd992fee45663edcbe3250c5d005b55576b7b4a237b2942482accc335824b27e05ff06e603d03758a9143c7000f3ce9b72a60429245e99c
diff --git a/dev-haskell/parsec1/metadata.xml b/dev-haskell/parsec1/metadata.xml
new file mode 100644
index 000000000000..b0ea7c4648b7
--- /dev/null
+++ b/dev-haskell/parsec1/metadata.xml
@@ -0,0 +1,34 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Parsec is designed from scratch as an industrial-strength parser
+ library. It is simple, safe, well documented (on the package
+ homepage), has extensive libraries and good error messages,
+ and is also fast.
+
+ This package is the core haskell98 part of the parsec2
+ package, intended to preserve its simplicity and portability.
+
+ Note, that the module names overlap with those of parsec from the Haskell
+ Platform, therefore I do not recommend to unconditionally use parsec1 (or
+ parsec2 and parsec3) as dependency in cabal files of packages for hackage.
+ But you may want to develop your code using these limited and portable
+ parsec1 functions and finally change the dependency from parsec1 to parsec
+ in order to avoid module ambiguities for users just installing your package.
+ Your own module ambiguities are best avoided by hiding packages.
+
+ This version only differs from the pervious one by improved error messages
+ for try (positions are not reset), tokens and thus string (longer
+ unexpected strings are now reported to match the error position).
+ The notFollowedBy-parser was generalized (as in parsec-3) so
+ characters in messages are now shown in single instead of double
+ quotes.
+ Also (as since parsec-3.1.2) lookAhead no longer consumes tokens on success
+ (so that the many-parser can detect this).
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/parsec1/parsec1-1.0.0.6.ebuild b/dev-haskell/parsec1/parsec1-1.0.0.6.ebuild
new file mode 100644
index 000000000000..6af89318f95b
--- /dev/null
+++ b/dev-haskell/parsec1/parsec1-1.0.0.6.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Portable monadic parser combinators"
+HOMEPAGE="http://www.cs.uu.nl/~daan/parsec.html"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"