summaryrefslogtreecommitdiff
path: root/dev-haskell/parallel-io
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/parallel-io
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/parallel-io')
-rw-r--r--dev-haskell/parallel-io/Manifest3
-rw-r--r--dev-haskell/parallel-io/metadata.xml19
-rw-r--r--dev-haskell/parallel-io/parallel-io-0.3.3-r2.ebuild32
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-haskell/parallel-io/Manifest b/dev-haskell/parallel-io/Manifest
new file mode 100644
index 000000000000..03f8441b234f
--- /dev/null
+++ b/dev-haskell/parallel-io/Manifest
@@ -0,0 +1,3 @@
+DIST parallel-io-0.3.3.tar.gz 9435 BLAKE2B 97d3e1343a20748173d9bc15e1bd84cde4e66f4e8bc916a18550c9f5e9c7a97a06861ab83db6ed3c7975da0142e287da0c6dc1c6483d9f78544564516181e650 SHA512 4d2ddb9ad4b3b362e431774495fa7e4cc4476768257f2915f3a6e64c1872a5bcf880d71e1f678997a23fbf9cfa22bc2b38df9f2866897d3cbb6d35e65eb542db
+EBUILD parallel-io-0.3.3-r2.ebuild 843 BLAKE2B d672e07ffdc6c656399512f67993eeba45864f9496bd3f2bab1fbe2f76e909af7a66f190ada51e2c44876ec2c4c970d517fbcfecb10c7a8801cef6553cfa231d SHA512 0475c9b5d0008b5f9376debd79be4c1e29a3d67a5f535f4be80360eb48026f4ca824a2f3933af449e04c2799ce6e6f9be8de66197511b383ab8b1362dfe905fa
+MISC metadata.xml 899 BLAKE2B d4f43c2b5febedc199fed9b9e7a1cd911b626f65a8c6eb8993f94740e708689792ce41850bdaa27a0e492016d126c144ef79ad4b3964b6fd1e5c75547aaee3a6 SHA512 9461bf5d5391ba700a775c4193d0d0dc96d96a5591a4db16352e21aeeeb0f7fd776e8cc4aee55d9f3bedf59444d34477e9da9b22ea14f44b8e9f333de1f9c2e0
diff --git a/dev-haskell/parallel-io/metadata.xml b/dev-haskell/parallel-io/metadata.xml
new file mode 100644
index 000000000000..a02ec8bbfe5a
--- /dev/null
+++ b/dev-haskell/parallel-io/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ This package provides combinators for sequencing IO actions onto a thread pool. The
+ thread pool is guaranteed to contain no more unblocked threads than a user-specified upper limit, thus
+ minimizing contention.
+
+ Furthermore, the parallel combinators can be used reentrantly - your parallel
+ actions can spawn more parallel actions - without violating this property of the thread pool.
+
+ The package is inspired by the thread &lt;http://thread.gmane.org/gmane.comp.lang.haskell.cafe/56499/focus=56521&gt;.
+ Thanks to Neil Mitchell and Bulat Ziganshin for some of the code this package is based on.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/parallel-io/parallel-io-0.3.3-r2.ebuild b/dev-haskell/parallel-io/parallel-io-0.3.3-r2.ebuild
new file mode 100644
index 000000000000..048d8362c8fb
--- /dev/null
+++ b/dev-haskell/parallel-io/parallel-io-0.3.3-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Combinators for executing IO actions in parallel on a thread pool"
+HOMEPAGE="http://batterseapower.github.com/parallel-io"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+#hackport: flags: -test -fuzz -benchmark
+
+RDEPEND=">dev-haskell/extensible-exceptions-0.1.0.1:=[profile?]
+ >=dev-haskell/random-1.0:=[profile?] <dev-haskell/random-1.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'random >= 1.0 && < 1.1' 'random >= 1.0 && < 1.2'
+}