summaryrefslogtreecommitdiff
path: root/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.10.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:19:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-14 23:22:23 +0100
commit4b19be30aa626b327c885dae62c559ec0e9fb935 (patch)
tree76e74807bc479502e13866b581b6bf86734ec634 /dev-haskell/pandoc-citeproc/pandoc-citeproc-0.10.4.ebuild
parent30d6f67c98d149508509d5e86f176d558793acc0 (diff)
gentoo resync : 13.10.2019
Diffstat (limited to 'dev-haskell/pandoc-citeproc/pandoc-citeproc-0.10.4.ebuild')
-rw-r--r--dev-haskell/pandoc-citeproc/pandoc-citeproc-0.10.4.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.10.4.ebuild b/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.10.4.ebuild
index 64db508e0edf..a89de2bce4e4 100644
--- a/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.10.4.ebuild
+++ b/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.10.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,7 +16,7 @@ SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
-IUSE="+bibutils debug embed_data_files test_citeproc unicode_collation"
+IUSE="+bibutils debug embed-data-files test-citeproc unicode_collation"
RESTRICT=test # execs a process dropping environment (with LD_PRELOAD)
@@ -40,24 +40,24 @@ RDEPEND=">=app-text/pandoc-1.16:=[profile?] <app-text/pandoc-2.1:=[profile?]
>=dev-lang/ghc-7.4.1:=
bibutils? ( >=dev-haskell/hs-bibutils-0.3:=[profile?] )
debug? ( dev-haskell/pretty-show:=[profile?] )
- test_citeproc? ( >=dev-haskell/temporary-1.1:=[profile?]
+ test-citeproc? ( >=dev-haskell/temporary-1.1:=[profile?]
>=dev-haskell/vector-0.10:=[profile?] )
- !test_citeproc? ( dev-haskell/vector:=[profile?] )
+ !test-citeproc? ( dev-haskell/vector:=[profile?] )
unicode_collation? ( dev-haskell/text-icu:=[profile?] )
!unicode_collation? ( dev-haskell/rfc5051:=[profile?] )
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.12
- test? ( !test_citeproc? ( >=dev-haskell/temporary-1.1 ) )
- embed_data_files? ( dev-haskell/hsb2hs )
+ test? ( !test-citeproc? ( >=dev-haskell/temporary-1.1 ) )
+ embed-data-files? ( dev-haskell/hsb2hs )
"
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag bibutils bibutils) \
$(cabal_flag debug debug) \
- $(cabal_flag embed_data_files embed_data_files) \
+ $(cabal_flag embed-data-files embed_data_files) \
--flag=-small_base \
- $(cabal_flag test_citeproc test_citeproc) \
+ $(cabal_flag test-citeproc test_citeproc) \
$(cabal_flag unicode_collation unicode_collation)
}