summaryrefslogtreecommitdiff
path: root/dev-haskell/options
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-haskell/options
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-haskell/options')
-rw-r--r--dev-haskell/options/Manifest5
-rw-r--r--dev-haskell/options/metadata.xml63
-rw-r--r--dev-haskell/options/options-1.2.1.1.ebuild30
3 files changed, 98 insertions, 0 deletions
diff --git a/dev-haskell/options/Manifest b/dev-haskell/options/Manifest
new file mode 100644
index 000000000000..78b24fc43019
--- /dev/null
+++ b/dev-haskell/options/Manifest
@@ -0,0 +1,5 @@
+DIST options-1.2.1.1.tar.gz 25327 SHA256 283eea9ae2c539830c6c65f5c03fb00626cfd1274da0526c285c146fc3065a62 SHA512 615a3767b74ca0ba2eae993f6e475963df2a0933f1e6c9bbfe35144c4dc6018af276144b2ec1b608b695dc7fca904784ebc63cd58a432f966588846cb36f94ea WHIRLPOOL b8a2a6f64d573ad355e82bbd3dbb7fa1c234f3a29ad26b5e3c24f6feaed9107cba29b7fa0ce54dff7e7054bf96f71f5cbe26a3410489c98eaf15286e1d25caf9
+EBUILD options-1.2.1.1.ebuild 860 SHA256 5e6f24aeac5d0b74fc4fd106d8051f04023c8c408e783dfe5ac8b0fea3c28596 SHA512 10cdbf905a60b8e8226cb2703ea5fda1042fb05d887a11bd2c4e4edccb9b2d84f674ee205c35d4da270a914f25178c7c3b8ddf13c10293bd313f5835ac49d4d3 WHIRLPOOL c84edb449010fe17d10b05d69519d34af5bcfe53d510534f8ac21fb87918091c34d6e7c8af7132bd6fea7bdff40d299fb7d6370410911a09fc10673ef0340b58
+MISC ChangeLog 3613 SHA256 70644011f13c841950c93ef0103502a2651849d59ef4af4189579679efe67359 SHA512 ff4e3450d79a02f6193cfd25120baabb23deb3c29c8aea3e6ceac19a6c7fd692f10742d126189cb517cc0ff39a61c40df00e81413f405be253af63959bc789c7 WHIRLPOOL 97d6e0f1f7f15862acd250f071129a9da9ff609d2b3d76c8df1d30f7fbc889bff34506c910d74e23dfa73514141cbc6fe31767f864b64af5d345d611c0481e50
+MISC ChangeLog-2015 1244 SHA256 a3f7241447af277fc64d60c77d710428c0fa6016e600150fcee0d4aaa7c9f355 SHA512 2309a50cafde8209e4ba0fa36ec18d93a626e1ced759b618832307e006b1a925dbd7a8de835f7c1f0d7f6116d3d837b7c27184f5d4b1ca86e2259115fc468b50 WHIRLPOOL d60e23f6ed5f6a6229ff29969a7d304c290d222923423441b2a93b66268d3dfa309a7ecd92483a78f24eb6e07061115a10be79cffab6dbefa2852522c1a51bb9
+MISC metadata.xml 1803 SHA256 ab203f398c0c87ba7d96f969d8b539a8a6670bee40552314da718916a8992716 SHA512 0ee4d11702f1f43fb4fbb5416b96fbcf5d56ce3280deaa0474acce57a00f172133b19a8ce204c76a1b89320e708b9e3eb2cefb0ed1306d45d131073a382cef27 WHIRLPOOL f120fe81b2bf33107525976bf58f94d03ab7ccd4de0d1c8935ea4770538dde8df4558e70022225795892f9c24bd98d28dae54dd1d2fa24154753b7071e571576
diff --git a/dev-haskell/options/metadata.xml b/dev-haskell/options/metadata.xml
new file mode 100644
index 000000000000..4d7ecf23aaee
--- /dev/null
+++ b/dev-haskell/options/metadata.xml
@@ -0,0 +1,63 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ The @options@ package lets library and application developers easily work
+ with command-line options.
+
+ The following example is a full program that can accept two options,
+ @--message@ and @--quiet@:
+
+ @
+ import Control.Applicative
+ import Options
+
+ data MainOptions = MainOptions
+ &amp;#x20; &amp;#x7b; optMessage :: String
+ &amp;#x20; , optQuiet :: Bool
+ &amp;#x20; &amp;#x7d;
+
+ instance 'Options' MainOptions where
+ &amp;#x20; defineOptions = pure MainOptions
+ &amp;#x20; \&lt;*\&gt; simpleOption \"message\" \"Hello world!\"
+ &amp;#x20; \"A message to show the user.\"
+ &amp;#x20; \&lt;*\&gt; simpleOption \"quiet\" False
+ &amp;#x20; \"Whether to be quiet.\"
+
+ main :: IO ()
+ main = runCommand $ \\opts args -&gt; do
+ &amp;#x20; if optQuiet opts
+ &amp;#x20; then return ()
+ &amp;#x20; else putStrLn (optMessage opts)
+ @
+
+ &gt;$ ./hello
+ &gt;Hello world!
+ &gt;$ ./hello --message='ciao mondo'
+ &gt;ciao mondo
+ &gt;$ ./hello --quiet
+ &gt;$
+
+ In addition, this library will automatically create documentation options
+ such as @--help@ and @--help-all@:
+
+ &gt;$ ./hello --help
+ &gt;Help Options:
+ &gt; -h, --help
+ &gt; Show option summary.
+ &gt; --help-all
+ &gt; Show all help options.
+ &gt;
+ &gt;Application Options:
+ &gt; --message :: text
+ &gt; A message to show the user.
+ &gt; default: "Hello world!"
+ &gt; --quiet :: bool
+ &gt; Whether to be quiet.
+ &gt; default: false
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/options/options-1.2.1.1.ebuild b/dev-haskell/options/options-1.2.1.1.ebuild
new file mode 100644
index 000000000000..4757f77492b0
--- /dev/null
+++ b/dev-haskell/options/options-1.2.1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A powerful and easy-to-use command-line option parser"
+HOMEPAGE="https://john-millikin.com/software/haskell-options/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+RESTRICT=test # circular depends
+
+RDEPEND=">=dev-haskell/monads-tf-0.1:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/chell-0.4 <dev-haskell/chell-0.5
+ >=dev-haskell/chell-quickcheck-0.2 <dev-haskell/chell-quickcheck-0.3 )
+"