summaryrefslogtreecommitdiff
path: root/dev-haskell/nonce
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/nonce
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/nonce')
-rw-r--r--dev-haskell/nonce/Manifest3
-rw-r--r--dev-haskell/nonce/metadata.xml21
-rw-r--r--dev-haskell/nonce/nonce-1.0.2.ebuild34
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-haskell/nonce/Manifest b/dev-haskell/nonce/Manifest
new file mode 100644
index 000000000000..afce242f5949
--- /dev/null
+++ b/dev-haskell/nonce/Manifest
@@ -0,0 +1,3 @@
+DIST nonce-1.0.2.tar.gz 2872 BLAKE2B ca6fe229e9682b91eee7886576eead09f47d259c760fc8e37d4c079ce810fa4ba3e08e53ef175ebe9787e7c921d3ab866fb2a446a116fde4a979d513b494dbdb SHA512 e47ed297c7aaa1ed98b6ce711cbc6653dbcbeba9b132750e588c9134f544e8b92b857f36a9331350711df14259dd0f54e49fa6e0da10e9334c5bf76952431894
+EBUILD nonce-1.0.2.ebuild 985 BLAKE2B f934f5e2384415345726b1ead0be72429deeeaf87a89a8d80e7d90fc5f6f4896ffa5314d461523f916c5366fe55290ae12ad937c5eedd49d63196b2b8c26ea9a SHA512 f7d6806b82c849f0121aca500f3e2e1e02c9fa4c55d668ec5e4ae955b4d4eb7fc2e7afa31e093eb7d0a0ead06694eed5c1cece9d203b2a2418417e34a2e9d19f
+MISC metadata.xml 806 BLAKE2B 6304bb46d197c2b8d88b4bc194e638e29abc7da6819dce3b310c2be1fc63dfba1b7dd03d5be52ba75709354aae8e5979440bb4c882de26040fd6e50ba8853898 SHA512 2e86de83f8508e9a698f2f0c09b1412a484050093fd1aed583bcd6378d6ff801b7956bcb7c261eb1b82825f2600715c7886fd00bf04774c005b8dba79bdc6960
diff --git a/dev-haskell/nonce/metadata.xml b/dev-haskell/nonce/metadata.xml
new file mode 100644
index 000000000000..ef3750fcd2b4
--- /dev/null
+++ b/dev-haskell/nonce/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ According to the Wikipedia, a nonce is an arbitrary number used
+ only once in a cryptographic communication. This package
+ contain helper functions for generating nonces.
+
+ There are many kinds of nonces used in different situations.
+ It's not guaranteed that by using the nonces from this package
+ you won't have any security issues. Please make sure that the
+ nonces generated via this package are usable on your design.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">prowdsponsor/nonce</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/nonce/nonce-1.0.2.ebuild b/dev-haskell/nonce/nonce-1.0.2.ebuild
new file mode 100644
index 000000000000..b7dcac58cf5e
--- /dev/null
+++ b/dev-haskell/nonce/nonce-1.0.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Generate cryptographic nonces"
+HOMEPAGE="https://github.com/prowdsponsor/nonce"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/base64-bytestring-1.0:=[profile?] <dev-haskell/base64-bytestring-1.1:=[profile?]
+ >=dev-haskell/cprng-aes-0.5:=[profile?] <dev-haskell/cprng-aes-0.7:=[profile?]
+ >=dev-haskell/crypto-random-0.0:=[profile?] <dev-haskell/crypto-random-0.1:=[profile?]
+ >=dev-haskell/text-0.9:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'base >= 4.5 && < 4.9' 'base >= 4.5'
+}