summaryrefslogtreecommitdiff
path: root/dev-haskell/mysql-simple/mysql-simple-0.4.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-22 02:42:13 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-22 02:42:13 +0100
commite7f37e03b952768321c8c943a80eff4152ea7bbd (patch)
tree355a9efb62297418cdadbc424b09dbafc54257e5 /dev-haskell/mysql-simple/mysql-simple-0.4.5.ebuild
parent2518522472e5de9c52c78dc0246475fe0ae3cc05 (diff)
gentoo auto-resync : 22:08:2022 - 02:42:13
Diffstat (limited to 'dev-haskell/mysql-simple/mysql-simple-0.4.5.ebuild')
-rw-r--r--dev-haskell/mysql-simple/mysql-simple-0.4.5.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-haskell/mysql-simple/mysql-simple-0.4.5.ebuild b/dev-haskell/mysql-simple/mysql-simple-0.4.5.ebuild
deleted file mode 100644
index 72f2b2c8d56c..000000000000
--- a/dev-haskell/mysql-simple/mysql-simple-0.4.5.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.6.9999
-#hackport: flags: developer:debug
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="A mid-level MySQL client library"
-HOMEPAGE="https://github.com/paul-rouse/mysql-simple"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug"
-
-RESTRICT=test # need running mysql, missing files
-
-RDEPEND=">=dev-haskell/attoparsec-0.10.0.0:=[profile?]
- dev-haskell/base16-bytestring:=[profile?]
- dev-haskell/blaze-builder:=[profile?]
- dev-haskell/blaze-textual:=[profile?]
- >=dev-haskell/mysql-0.1.1.1:=[profile?]
- dev-haskell/old-locale:=[profile?]
- dev-haskell/pcre-light:=[profile?]
- >=dev-haskell/semigroups-0.11:=[profile?] <dev-haskell/semigroups-0.19:=[profile?]
- >=dev-haskell/text-0.11.0.2:=[profile?]
- >=dev-lang/ghc-7.4.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.8
- test? ( dev-haskell/hspec )
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag debug developer)
-}