summaryrefslogtreecommitdiff
path: root/dev-haskell/monad-loops
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/monad-loops
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/monad-loops')
-rw-r--r--dev-haskell/monad-loops/Manifest3
-rw-r--r--dev-haskell/monad-loops/metadata.xml18
-rw-r--r--dev-haskell/monad-loops/monad-loops-0.4.3.ebuild26
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-haskell/monad-loops/Manifest b/dev-haskell/monad-loops/Manifest
new file mode 100644
index 000000000000..3f4681909a6e
--- /dev/null
+++ b/dev-haskell/monad-loops/Manifest
@@ -0,0 +1,3 @@
+DIST monad-loops-0.4.3.tar.gz 4996 BLAKE2B cbe025073cdf7ce193854de927ff34981709a206ee1061cd0dbf26b09a533fe5c3da961e9c5c77ec63bca9963eb4104399eb5d38eaef416df13138a4372dc562 SHA512 41a1314777661a411acf62dfa25cbb1a59fedd5d60d1a2b8566a3dd64dec361ab1fe35827320529a723a612e0443571ce38b17fa900eb8d5289bc52f653d47a5
+EBUILD monad-loops-0.4.3.ebuild 598 BLAKE2B 80331fdbe160c97b034644c461dcb64cd41865640cd0e14573b156c36dd6c92ea326040f2f54ff61d5fd4b981f8cd786891e64c968a0c1cd3c9d99cad48f1a21 SHA512 865444f59419a4afe0cbc308c5a0762217d36d1eaae11d05471118672617a5dcb04ab4ae412f6e6c705f5b40b8e51d334944f2e0925254d0d6831bb2c40e4420
+MISC metadata.xml 569 BLAKE2B 9a474ceee93931a469d0331c18c69c11d9ae4eba19a827c60c797c95521bcd8222909db352ba6ede8cc400c79375850a63f1afe4e60534a80e5f199c357bcb80 SHA512 57118fc45a4f8448e8943bc3b59b18c2b00e9f31297623a764ca88e715c6d6c273bdc953fa541747302fa4f2c24f96d62ae17f07b238df7e14a36d95f4cfbe4c
diff --git a/dev-haskell/monad-loops/metadata.xml b/dev-haskell/monad-loops/metadata.xml
new file mode 100644
index 000000000000..c766ee1f8714
--- /dev/null
+++ b/dev-haskell/monad-loops/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Some useful control operators for looping.
+
+ New in 0.3.2.0: various functions for traversing lists and
+ computing minima/maxima using arbitrary procedures to compare
+ or score the elements.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">mokus0/monad-loops</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/monad-loops/monad-loops-0.4.3.ebuild b/dev-haskell/monad-loops/monad-loops-0.4.3.ebuild
new file mode 100644
index 000000000000..7325375be662
--- /dev/null
+++ b/dev-haskell/monad-loops/monad-loops-0.4.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Monadic loops"
+HOMEPAGE="https://github.com/mokus0/monad-loops"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/tasty
+ dev-haskell/tasty-hunit )
+"