summaryrefslogtreecommitdiff
path: root/dev-haskell/mime-mail
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/mime-mail
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/mime-mail')
-rw-r--r--dev-haskell/mime-mail/Manifest3
-rw-r--r--dev-haskell/mime-mail/metadata.xml14
-rw-r--r--dev-haskell/mime-mail/mime-mail-0.4.11.ebuild29
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-haskell/mime-mail/Manifest b/dev-haskell/mime-mail/Manifest
new file mode 100644
index 000000000000..ecfb3a1fa7b0
--- /dev/null
+++ b/dev-haskell/mime-mail/Manifest
@@ -0,0 +1,3 @@
+DIST mime-mail-0.4.11.tar.gz 8918 BLAKE2B 9d335f1953584961e377bdf041b7e93cf6a6e09d8ad3d86410bc565628a4aa75ad93a0bcdd484a566d88b36e1708ae32fdaa8a18424bf5135b5e44c16e9fa46e SHA512 576390c99ebfb390a4e3b2c441add80923033d91160aa834ee8b4491e117645d5ce2936fee798370feda8c21c477c95a1984314b28235a3cfcb5f72b2fc52a54
+EBUILD mime-mail-0.4.11.ebuild 795 BLAKE2B a554a97ebae213d9c14ce494dd64e77218e0008496fb76d4a9058b9b697bccd94d6ed1bb3cf7a0e323949073611d2bc9825b111073deb5253bb130d9b58d8373 SHA512 934553c0d3533d083469901f11a2301647c8c1075911abd9b50be1b4bc4f7f2c4fed55641d8a60a85aca65c6580546a20b158b877e600bff39fa9a0309f95823
+MISC metadata.xml 679 BLAKE2B 28d9585da38bec4e07e2f7b1a758b29d7316479d1e3b87d2b2cf9a56e71bcb3f07560746859f1e2caeda4ed53eaf4b11f9b3ebcb6c1ecc587a69f7d44edc71e6 SHA512 69cc2fb2efbafbca17649f2342f25204a74bb68270fd34decb797a97c7cdac3057de79cf84e0e7e5b85986fa3bbca3b80771acdabeed25a85308eb0aa162f071
diff --git a/dev-haskell/mime-mail/metadata.xml b/dev-haskell/mime-mail/metadata.xml
new file mode 100644
index 000000000000..abcd14239f1e
--- /dev/null
+++ b/dev-haskell/mime-mail/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ This package provides some high-level datatypes for declaring MIME email messages, functions for automatically composing these into bytestrings, and the ability to send bytestrings via the sendmail executable. You can also use any other library you wish to send via different methods, eg directly to SMTP.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">snoyberg/mime-mail</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/mime-mail/mime-mail-0.4.11.ebuild b/dev-haskell/mime-mail/mime-mail-0.4.11.ebuild
new file mode 100644
index 000000000000..eb3d46a288bb
--- /dev/null
+++ b/dev-haskell/mime-mail/mime-mail-0.4.11.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Compose MIME email messages"
+HOMEPAGE="https://github.com/snoyberg/mime-mail"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/base64-bytestring-0.1:=[profile?]
+ >=dev-haskell/blaze-builder-0.2.1:=[profile?] <dev-haskell/blaze-builder-0.5:=[profile?]
+ >=dev-haskell/random-1.0:=[profile?]
+ >=dev-haskell/text-0.7:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-1.3 )
+"