summaryrefslogtreecommitdiff
path: root/dev-haskell/microstache/microstache-1.0.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-haskell/microstache/microstache-1.0.1.1.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-haskell/microstache/microstache-1.0.1.1.ebuild')
-rw-r--r--dev-haskell/microstache/microstache-1.0.1.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-haskell/microstache/microstache-1.0.1.1.ebuild b/dev-haskell/microstache/microstache-1.0.1.1.ebuild
new file mode 100644
index 000000000000..9286cf331bb4
--- /dev/null
+++ b/dev-haskell/microstache/microstache-1.0.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Mustache templates for Haskell"
+HOMEPAGE="https://github.com/phadej/microstache"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/aeson-0.11:=[profile?]
+ >=dev-haskell/parsec-3.1.11:=[profile?] <dev-haskell/parsec-6.0:=[profile?]
+ >=dev-haskell/semigroups-0.18:=[profile?] <dev-haskell/semigroups-0.19:=[profile?]
+ >=dev-haskell/text-1.2:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.5:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/vector-0.11:=[profile?] <dev-haskell/vector-0.13:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( >=dev-haskell/hspec-2.0 <dev-haskell/hspec-3.0 )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'aeson >=0.11 && < 1.3' 'aeson >=0.11' \
+ 'containers >=0.4.2.1 && < 0.6' 'containers >=0.4.2.1'
+}