summaryrefslogtreecommitdiff
path: root/dev-haskell/microlens-aeson/microlens-aeson-2.3.0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-haskell/microlens-aeson/microlens-aeson-2.3.0.4.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-haskell/microlens-aeson/microlens-aeson-2.3.0.4.ebuild')
-rw-r--r--dev-haskell/microlens-aeson/microlens-aeson-2.3.0.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-haskell/microlens-aeson/microlens-aeson-2.3.0.4.ebuild b/dev-haskell/microlens-aeson/microlens-aeson-2.3.0.4.ebuild
new file mode 100644
index 000000000000..813122c70617
--- /dev/null
+++ b/dev-haskell/microlens-aeson/microlens-aeson-2.3.0.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Law-abiding lenses for Aeson, using microlens"
+HOMEPAGE="https://github.com/fosskers/microlens-aeson/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/aeson-0.7:=[profile?]
+ >=dev-haskell/attoparsec-0.10:=[profile?]
+ >=dev-haskell/microlens-0.3:=[profile?]
+ >=dev-haskell/scientific-0.3.2:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.3:=[profile?]
+ >=dev-haskell/vector-0.9:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2
+ test? ( >=dev-haskell/tasty-0.10.1.2
+ >=dev-haskell/tasty-hunit-0.9.2 )
+"