summaryrefslogtreecommitdiff
path: root/dev-haskell/lvmlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/lvmlib
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/lvmlib')
-rw-r--r--dev-haskell/lvmlib/Manifest4
-rw-r--r--dev-haskell/lvmlib/files/lvmlib-1.1-ghc-7.10.patch87
-rw-r--r--dev-haskell/lvmlib/lvmlib-1.1.ebuild30
-rw-r--r--dev-haskell/lvmlib/metadata.xml17
4 files changed, 138 insertions, 0 deletions
diff --git a/dev-haskell/lvmlib/Manifest b/dev-haskell/lvmlib/Manifest
new file mode 100644
index 000000000000..24e2d9c20d3f
--- /dev/null
+++ b/dev-haskell/lvmlib/Manifest
@@ -0,0 +1,4 @@
+AUX lvmlib-1.1-ghc-7.10.patch 2590 BLAKE2B 165938d0813dbf6806068ffa4e72c695d1a56eac4a7c2ba31a2dab12fca0549ff7210273eaa23039ad2f0d794727d541d0520609745e9bdcbcedcf8538c45931 SHA512 a645db9a37614752afa29d176133ee237511773e1d7c8d2f5959828264ad909360f441673b3e6bef5137bb0deb2f1eb108371032fafaa77a86d5a7be5fec2867
+DIST lvmlib-1.1.tar.gz 62388 BLAKE2B 9effe8b0b71ef36b3f73e792a9702d44efa5a7ed9f48f35825d75706a7dad2d5f5cac06d5941f60730c79216af5f3009110919dfa397343287e7359e702c5fbc SHA512 3f085f3ff8e53ab19de3b425c4c5a271111afcd334ec08fefd983838608ae436005c20c2d7c545650f0dd1b76d466f81661a14c8ce972df27d79a78c22023861
+EBUILD lvmlib-1.1.ebuild 699 BLAKE2B fd9a0a1d3b2f97a88bf183eacfd628659a6823c2e4649e07e475df22a7cf0ba9330e64d3e412c70412184d3f7eb59a597c32351898552af4f6b84e1341e83b38 SHA512 24c6d760a95b75f996a803d01099bf7a7c75edc07de5b5422f21d36db1825fc2e53fb082f79fec75764e99215b98a14fac089803eaa64445f4a526669022ce9b
+MISC metadata.xml 822 BLAKE2B 6c75a01261fb049e7b175c7f4b8de7da8978bca198f5a55581630087682920da280185d6c1512a81a0e05bbe02b8728b8261564c4d7d6a15db67218baa47f5b6 SHA512 95c53741b0af7d02006f5715e9468b01d984c5145a4f0582f268da5c3ef19c7902d7a9fe48a8b07c1825dbe9a8e09cc03c208a405218ec930b72ddd9e9d31219
diff --git a/dev-haskell/lvmlib/files/lvmlib-1.1-ghc-7.10.patch b/dev-haskell/lvmlib/files/lvmlib-1.1-ghc-7.10.patch
new file mode 100644
index 000000000000..ad68d78f56e7
--- /dev/null
+++ b/dev-haskell/lvmlib/files/lvmlib-1.1-ghc-7.10.patch
@@ -0,0 +1,87 @@
+diff --git a/Lvm/Asm/Data.hs b/Lvm/Asm/Data.hs
+index 7939754..f3da0b7 100644
+--- a/Lvm/Asm/Data.hs
++++ b/Lvm/Asm/Data.hs
+@@ -17,2 +17,3 @@ import Lvm.Core.Module
+ import Text.PrettyPrint.Leijen
++import Prelude hiding ((<$>))
+
+diff --git a/Lvm/Common/IdMap.hs b/Lvm/Common/IdMap.hs
+index a50bcb6..10758e6 100644
+--- a/Lvm/Common/IdMap.hs
++++ b/Lvm/Common/IdMap.hs
+@@ -24,2 +24,3 @@ import Lvm.Common.Id
+ import Control.Arrow (first)
++import Prelude hiding (foldMap)
+
+diff --git a/Lvm/Core/Expr.hs b/Lvm/Core/Expr.hs
+index 8bc50d7..935e16a 100644
+--- a/Lvm/Core/Expr.hs
++++ b/Lvm/Core/Expr.hs
+@@ -17,2 +17,3 @@ import Lvm.Core.PrettyId
+ import Text.PrettyPrint.Leijen
++import Prelude hiding ((<$>))
+
+diff --git a/Lvm/Core/Module.hs b/Lvm/Core/Module.hs
+index 923870e..ac52201 100644
+--- a/Lvm/Core/Module.hs
++++ b/Lvm/Core/Module.hs
+@@ -24,2 +24,3 @@ import Lvm.Instr.Data
+ import Text.PrettyPrint.Leijen
++import Prelude hiding ((<$>))
+
+diff --git a/Lvm/Instr/Data.hs b/Lvm/Instr/Data.hs
+index 497a690..959cb5c 100644
+--- a/Lvm/Instr/Data.hs
++++ b/Lvm/Instr/Data.hs
+@@ -19,2 +19,3 @@ import Lvm.Common.Id
+ import Text.PrettyPrint.Leijen
++import Prelude hiding ((<$>))
+
+diff --git a/Lvm/Instr/Resolve.hs b/Lvm/Instr/Resolve.hs
+index 6845f74..4172a74 100644
+--- a/Lvm/Instr/Resolve.hs
++++ b/Lvm/Instr/Resolve.hs
+@@ -10,2 +10,4 @@ module Lvm.Instr.Resolve (instrResolve) where
+ import Control.Exception (assert)
++import Control.Applicative
++import Control.Monad
+ import Data.Maybe
+@@ -32,2 +34,6 @@ instance Functor Resolve where
+
++instance Applicative Resolve where
++ pure = return
++ (<*>) = ap -- defined in Control.Monad
++
+ instance Monad Resolve where
+diff --git a/Lvm/Read.hs b/Lvm/Read.hs
+index 7137331..25797f9 100644
+--- a/Lvm/Read.hs
++++ b/Lvm/Read.hs
+@@ -9,2 +9,3 @@ module Lvm.Read (lvmReadFile, lvmRead) where
+
++import Control.Applicative
+ import Control.Monad
+@@ -390,2 +391,7 @@ instance Functor (Read v) where
+ Result x st2 -> Result (f x) st2)
++
++instance Applicative (Read v) where
++ pure = return
++ (<*>) = ap -- defined in Control.Monad
++
+ instance Monad (Read v) where
+diff --git a/Lvm/Write.hs b/Lvm/Write.hs
+index 48570f8..37469bc 100644
+--- a/Lvm/Write.hs
++++ b/Lvm/Write.hs
+@@ -11,2 +11,3 @@ import qualified Control.Exception as CE (assert, catch, IOException)
+ import Control.Monad
++import Control.Applicative
+ import Data.Maybe
+@@ -465,2 +466,6 @@ instance Functor Emit where
+
++instance Applicative Emit where
++ pure = return
++ (<*>) = ap -- defined in Control.Monad
++
+ instance Monad Emit where
diff --git a/dev-haskell/lvmlib/lvmlib-1.1.ebuild b/dev-haskell/lvmlib/lvmlib-1.1.ebuild
new file mode 100644
index 000000000000..0b49945b9a5b
--- /dev/null
+++ b/dev-haskell/lvmlib/lvmlib-1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit eutils haskell-cabal
+
+DESCRIPTION="The Lazy Virtual Machine (LVM)"
+HOMEPAGE="http://www.cs.uu.nl/wiki/bin/view/Helium/WebHome"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/parsec:=[profile?]
+ dev-haskell/wl-pprint:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10.1.0
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.1-ghc-7.10.patch
+}
diff --git a/dev-haskell/lvmlib/metadata.xml b/dev-haskell/lvmlib/metadata.xml
new file mode 100644
index 000000000000..2d49cd8f1b3c
--- /dev/null
+++ b/dev-haskell/lvmlib/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ The Lazy Virtual Machine (LVM) defines a portable instruction set and file
+ format. It is specifically designed to execute languages with non-strict (or
+ lazy) semantics. This cabal package defines the core assembler (coreasm) for
+ compiling core programs into LVM instructions and a library. The LVM is used
+ as a backend for the Helium compiler. At the moment, one LVM runtime
+ implementation is available (written in C). More information about LVM can be
+ found in Chapter 6 of Daan Leijen's PhD Thesis, The Lambda Abroad.
+ </longdescription>
+</pkgmetadata>