summaryrefslogtreecommitdiff
path: root/dev-haskell/lua
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-23 02:48:52 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-23 02:48:52 +0100
commitfd70f5e3ed54d5e013c11a3f3e632e80838171d0 (patch)
treec6bf0dac8239e644ccc09b184e4eb9cca9701dcf /dev-haskell/lua
parent5deadca7219297a3c1f90eca00544a00e33efdbc (diff)
gentoo auto-resync : 23:07:2022 - 02:48:51
Diffstat (limited to 'dev-haskell/lua')
-rw-r--r--dev-haskell/lua/Manifest5
-rw-r--r--dev-haskell/lua/lua-2.1.0.ebuild39
-rw-r--r--dev-haskell/lua/lua-2.2.0.ebuild38
-rw-r--r--dev-haskell/lua/metadata.xml31
4 files changed, 113 insertions, 0 deletions
diff --git a/dev-haskell/lua/Manifest b/dev-haskell/lua/Manifest
new file mode 100644
index 000000000000..f647a3bbc4e4
--- /dev/null
+++ b/dev-haskell/lua/Manifest
@@ -0,0 +1,5 @@
+DIST lua-2.1.0.tar.gz 212562 BLAKE2B 916eb056d5e920492821c21fb7a51e2f6cde7d5b17462378baa3fc00f22d4a1ac0435e2671fb3d7d722a972beed5d267c587790e0fa9d066ac3a5af3fd988954 SHA512 1360e163915e14381e457727e0d04abc089fef95b6c14331b355330ec35458d5ddf899f843ce61dffe23b86ceffd0d203fd66f2edb4cc8ce11f00278842e1a94
+DIST lua-2.2.0.tar.gz 260005 BLAKE2B ec79108a72a6060fc82b94aac1e61c51aea0d570bac37add749654d903fec5b62c5caa82932606e9778431c80c68fceb11b5eba9d6c45c183a8f249934d26c55 SHA512 d19f54c9424773557f7ef7929be84dfcb7624d8a617d3383a771fe1ba7d6d5cd724c8fcd40475cde443e02e0cf3164a8869c0d67c90cf04b3b09ef6d876aa727
+EBUILD lua-2.1.0.ebuild 1043 BLAKE2B 2011e4c60ff598acfa868e5eb97be2c81f6f33db31541867cfb22b818a5e0bfa2140ab917766750384f8d50cf424c86db58b8b0078983e78a62b6f0f56da5dc6 SHA512 12b533fdc05e7bef0cf792e3d41c814eed2193086f69b7e1f485708fe25db0aeb00cfef2297a0263a30c161f9a3d91e830386017e70111361ba57b36e5e076ad
+EBUILD lua-2.2.0.ebuild 974 BLAKE2B 0d05aaa0abfd7c13d93b3f2a0fb889e09cbbaacd9f7955b5a7b01955df04079b4c2a5186be9c6b6dffdc1819e63bcc9133e8d99f94b4cf941594ce107f98740f SHA512 b9626c98c475d29723965c65284574eeeb8fd75877e0055c6acd9520730a0b3270b824a5a406f75fd7160cf9c8c45c8f3edebb02d189d96aad12ba35a9e7171c
+MISC metadata.xml 1490 BLAKE2B c7d87f47e0c30b9d5ffa4a6dac6c510aed19ade3913c1eb16e0a1dc39a6109f8c7542f34cd9a25f1af29b9ad22a871e9d1e7cac034a9197c04471438f66fa013 SHA512 0a408256cf63e205508615b7a5df1bff64de5b1a101ae7ea48a666a7327ee0ff2a104b29117d9593ad63b3640132bdbdd5a51f28c64062e2d71ef8216ebb5aa3
diff --git a/dev-haskell/lua/lua-2.1.0.ebuild b/dev-haskell/lua/lua-2.1.0.ebuild
new file mode 100644
index 000000000000..e3d79624aa13
--- /dev/null
+++ b/dev-haskell/lua/lua-2.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+#hackport: flags: -allow-unsafe-gc,-apicheck,-export-dynamic,-lua_32bits,+pkgconfig,+system-lua
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Lua, an embeddable scripting language"
+HOMEPAGE="https://hslua.org/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="+allow-unsafe-gc apicheck +export-dynamic +hardcode-reg-keys lua-32bits"
+
+RDEPEND=">=dev-lang/ghc-8.4.3:=
+ dev-lang/lua:5.3
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( >=dev-haskell/tasty-0.11
+ >=dev-haskell/tasty-hunit-0.9 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-allow-unsafe-gc \
+ --flag=-apicheck \
+ --flag=-export-dynamic \
+ $(cabal_flag hardcode-reg-keys hardcode-reg-keys) \
+ --flag=-lua_32bits \
+ --flag=pkg-config \
+ --flag=system-lua
+}
diff --git a/dev-haskell/lua/lua-2.2.0.ebuild b/dev-haskell/lua/lua-2.2.0.ebuild
new file mode 100644
index 000000000000..3562e0330b6e
--- /dev/null
+++ b/dev-haskell/lua/lua-2.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+#hackport: flags: -allow-unsafe-gc,-apicheck,-export-dynamic,-lua_32bits,pkg-config:system-lua
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Lua, an embeddable scripting language"
+HOMEPAGE="https://hslua.org/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="system-lua"
+
+RDEPEND=">=dev-lang/ghc-8.4.3:=
+ system-lua? ( dev-lang/lua:5.4 )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( >=dev-haskell/tasty-0.11
+ >=dev-haskell/tasty-hunit-0.9 )
+ system-lua? ( virtual/pkgconfig )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-allow-unsafe-gc \
+ --flag=-apicheck \
+ --flag=-export-dynamic \
+ --flag=-lua_32bits \
+ $(cabal_flag system-lua pkg-config)
+}
diff --git a/dev-haskell/lua/metadata.xml b/dev-haskell/lua/metadata.xml
new file mode 100644
index 000000000000..5b1e564f95ae
--- /dev/null
+++ b/dev-haskell/lua/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <use>
+ <flag name="allow-unsafe-gc">Allow optimizations which make Lua&#39;s garbage collection
+potentially unsafe; enabling this should be safe if
+there are no callbacks into Haskell during Lua garbage
+collection cycles. The flag should be *disabled* if Lua
+objects can have Haskell finalizers, i.e., @__gc@
+metamethods that call Haskell function.</flag>
+ <flag name="apicheck">Compile Lua with -DLUA_USE_APICHECK.</flag>
+ <flag name="export-dynamic">Add all symbols to dynamic symbol table; disabling this
+will make it possible to create fully static binaries,
+but renders loading of dynamic C libraries impossible.</flag>
+ <flag name="hardcode-reg-keys">Don&#39;t use CAPI to determine the names of certain
+registry key names but use hard coded values instead.
+This flag is required when compiling against Lua 5.3.3
+or earlier, as those versions do not expose the
+necessary information in the @lauxlib.h@ header file.
+Setting this flag should usually be unproblematic,
+except if the used Lua version has been patched
+heavily.</flag>
+ <flag name="lua-32bits">Compile Lua with -DLUA_32BITS</flag>
+ <flag name="system-lua">Use @pkg-config@ to discover library and include paths.
+Setting this flag implies `pkg-config`.</flag>
+ </use>
+</pkgmetadata>