summaryrefslogtreecommitdiff
path: root/dev-haskell/lrucache
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-haskell/lrucache
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-haskell/lrucache')
-rw-r--r--dev-haskell/lrucache/Manifest3
-rw-r--r--dev-haskell/lrucache/lrucache-1.2.0.1.ebuild25
-rw-r--r--dev-haskell/lrucache/metadata.xml48
3 files changed, 76 insertions, 0 deletions
diff --git a/dev-haskell/lrucache/Manifest b/dev-haskell/lrucache/Manifest
new file mode 100644
index 000000000000..6fa032ebc074
--- /dev/null
+++ b/dev-haskell/lrucache/Manifest
@@ -0,0 +1,3 @@
+DIST lrucache-1.2.0.1.tar.gz 9224 BLAKE2B d29cfee3d21fcf66318f272011551a1a04e17ccac5ba58da0a80591502488ab7446a5b2137c57c91ded80b2486d95c28f5449c5417c88a99f2e121dd17841eea SHA512 fae5c8a10bb7ee781ed84ccf9c342bd583e112eb840d07aa72803affe3fa7dd394b3d6b73212e45005ec9155a409539902c4893ce20dc0a2a0e3f4a44b2c715b
+EBUILD lrucache-1.2.0.1.ebuild 610 BLAKE2B e22cf7559c1decb103836df9825714fb208981bb9a824aade38d89fa9461f630f00b57018ecd823d057b2647458cd1b6fe70e420e9e942b78b367ede8c1ba6bf SHA512 5511e51629550673002bc19218ecb62b3c2a2f1635959631197e3e2860f5bac20e3afa5812abc0b8fa3d9a904067385209c3a99467da8dbbd1584cfdd7d252de
+MISC metadata.xml 1464 BLAKE2B 820e94e46a846cf795c521dace49f7daebda65431203d626f654b76a8f86fdd8b7b1ba216fa87cd123ffbab3aafcf693509610b1469ebf2780ce930e1058432f SHA512 1d9053a57a2002837ce24447504284a96891304ed4e5dbd12a312573c576271e1974021d2147cfb1637039b307f0d6b202ef388efa7a9787d7cce88f070b0875
diff --git a/dev-haskell/lrucache/lrucache-1.2.0.1.ebuild b/dev-haskell/lrucache/lrucache-1.2.0.1.ebuild
new file mode 100644
index 000000000000..48b8f20f6e50
--- /dev/null
+++ b/dev-haskell/lrucache/lrucache-1.2.0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="a simple, pure LRU cache"
+HOMEPAGE="https://github.com/chowells79/lrucache"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/contravariant-0.5:=[profile?] <dev-haskell/contravariant-2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
diff --git a/dev-haskell/lrucache/metadata.xml b/dev-haskell/lrucache/metadata.xml
new file mode 100644
index 000000000000..832a2c27f608
--- /dev/null
+++ b/dev-haskell/lrucache/metadata.xml
@@ -0,0 +1,48 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ This package contains a simple, pure LRU cache, implemented in
+ terms of "Data.Map".
+
+ It also contains a mutable IO wrapper providing atomic updates to
+ an LRU cache.
+
+ Version History:
+
+ 1.1.1 - Add an additional modification function for AtomicLRUCache.
+
+ 1.1.0.1 - Update containers constraint to allow containers from ghc-7
+
+ 1.1 - Add a Functor instance for LRUCache.
+ Add a generic modification function for AtomicLRUCache.
+
+ 1.0 - Breaking API changes:
+ 1) The newLRU smart constructor now makes the maximum
+ size optional.
+ 2) The delete function now returns the value removed, if
+ one was.
+ Additionally, a function was added to remove the least-recently
+ used element in the LRU.
+
+ 0.3 - Added a Show instance for LRU. (Requested by Ben Lee)
+
+ 0.2.0.1 - Increase strictness slightly.
+ Remove cabal target for test executable.
+ (Just include test sources instead.)
+
+ 0.2 - Added an Eq instance for LRU.
+ Added strictness to eliminate space leaks in common use patterns.
+
+ 0.1.1 - Add the Data.Cache.LRU.IO.Internal module.
+ Clean up build warnings on GHC 6.12.1.
+
+ 0.1.0.1 - Minor refactoring
+
+ 0.1 - First release
+ </longdescription>
+</pkgmetadata>