summaryrefslogtreecommitdiff
path: root/dev-haskell/listlike
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/listlike
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/listlike')
-rw-r--r--dev-haskell/listlike/Manifest6
-rw-r--r--dev-haskell/listlike/files/listlike-4.2.1-QC-2.8.2.patch12
-rw-r--r--dev-haskell/listlike/listlike-4.2.1.ebuild40
-rw-r--r--dev-haskell/listlike/listlike-4.5.1.ebuild37
-rw-r--r--dev-haskell/listlike/metadata.xml20
5 files changed, 115 insertions, 0 deletions
diff --git a/dev-haskell/listlike/Manifest b/dev-haskell/listlike/Manifest
new file mode 100644
index 000000000000..76f30ca70050
--- /dev/null
+++ b/dev-haskell/listlike/Manifest
@@ -0,0 +1,6 @@
+AUX listlike-4.2.1-QC-2.8.2.patch 478 BLAKE2B 974c6b65457fbfd19802c6ba8190d85a80f0939636ef65d32ae0e684e62b919c5298682fbcca851103a3969f00042449ab53f44671f5bcca76cb37b9a80d6e6f SHA512 204905c3a34da9c1acbb2be70264304e54f2bc6e9f457217b1d8b5c93380b842189cabb8082e100878b06f6852e02875fc253185c4b1e6f8b6af47b1244b2bee
+DIST ListLike-4.2.1.tar.gz 26970 BLAKE2B bac409776f37ba43f1e1bfa06424ed823866735cbb7b05d30cb98a9620b05891d651e10fd0a1c2c10642ad6215e2de9554221ab3edc6060c7f7cef51b4561c67 SHA512 dc245b4c2bc4fa0ea24efe55434eb8c7b2f2ee1a078fef331997bb0311260732970255fc8a18c9a7f22d90f47f661e543d18e6ad60b8d46992a6e973ccd375ad
+DIST ListLike-4.5.1.tar.gz 29600 BLAKE2B bc6b54b91e95ea8340db305975ee3b5ab5239989db518930353fffb643d29a23d8634d2760cd39729389fe983b553a3a7816a939d583f9470cc56284150d1568 SHA512 4e59eb8cdade42ff63db9f90a7ec524dab674872960bd294da3195c280e0f488a3c0acb3827def8a071e5ecd820bb2bf0d5d68c22b8388adc933accbb0bcc630
+EBUILD listlike-4.2.1.ebuild 1147 BLAKE2B f355f02be1cbc5aaa5f78a33b56bff5a2fc7536d69929d4b7f08e0736523351fc8ddb4972461ff24a54988abe7db89a37f1573c07edc45e9ca2ffd22f2349ce2 SHA512 00791b93c4ec3670f19ba7bb79ae6938de3585e894db6748017c5d37700e766382bbd469c756afbc7659f9c0762ea4d995c298529140753a02cce4bda0b14120
+EBUILD listlike-4.5.1.ebuild 1122 BLAKE2B cf4f63ad25aa2e25bf0dc946657bac0e1f3874c72e509f9803c6b89538800ed4e41f244149905ac9fa5172bf88a9e93d41db8dc85ee4cd1676ef8ae129ce32e2 SHA512 236e7399aa7a771ad327aa699566f3b45ff2d4406a8983dc642c97372442d409dc06e1aa95a1dac076a7679eda5c61d1619b982f58356ca02379e4b7f5732458
+MISC metadata.xml 783 BLAKE2B 3c3966a1f248069416a91328590f1ab7f279f3c4d6749f6036fca194c012fe13688a9bbaa318cb26e538e7071d98e134f62db06d5c9f338e993d15b0af5f558c SHA512 379416d891112c98837e72159adf825753c340fdc0147e64acb7ab2b9c03052452124e7c1d2f3d585c545f0b92a0a8d4bc865c19256847b4bd0b702c72d20499
diff --git a/dev-haskell/listlike/files/listlike-4.2.1-QC-2.8.2.patch b/dev-haskell/listlike/files/listlike-4.2.1-QC-2.8.2.patch
new file mode 100644
index 000000000000..1615c29047e2
--- /dev/null
+++ b/dev-haskell/listlike/files/listlike-4.2.1-QC-2.8.2.patch
@@ -0,0 +1,12 @@
+diff --git a/testsrc/TestInfrastructure.hs b/testsrc/TestInfrastructure.hs
+index f4d574e..d427495 100644
+--- a/testsrc/TestInfrastructure.hs
++++ b/testsrc/TestInfrastructure.hs
+@@ -76,2 +76,3 @@ instance (CoArbitrary i) => CoArbitrary (FM.FMList i) where
+
++#if ! MIN_VERSION_QuickCheck(2,8,2)
+ instance (Arbitrary i) => Arbitrary (S.Seq i) where
+@@ -85,2 +86,3 @@ instance (CoArbitrary i) => CoArbitrary (S.Seq i) where
+ coarbitrary l = coarbitrary (LL.toList l)
++#endif
+
diff --git a/dev-haskell/listlike/listlike-4.2.1.ebuild b/dev-haskell/listlike/listlike-4.2.1.ebuild
new file mode 100644
index 000000000000..ff8f2b60b800
--- /dev/null
+++ b/dev-haskell/listlike/listlike-4.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+MY_PN="ListLike"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Generic support for list-like structures"
+HOMEPAGE="http://software.complete.org/listlike"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/dlist-0.7:=[profile?] <dev-haskell/dlist-0.9:=[profile?]
+ >=dev-haskell/fmlist-0.8:=[profile?] <dev-haskell/fmlist-0.10:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/vector-0.5:=[profile?] <dev-haskell/vector-0.12:=[profile?]
+ >=dev-lang/ghc-7.6.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+ test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-2
+ >=dev-haskell/quickcheck-2.4 <dev-haskell/quickcheck-3
+ >=dev-haskell/random-1 <dev-haskell/random-2 )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-QC-2.8.2.patch
+}
diff --git a/dev-haskell/listlike/listlike-4.5.1.ebuild b/dev-haskell/listlike/listlike-4.5.1.ebuild
new file mode 100644
index 000000000000..6af494f5a943
--- /dev/null
+++ b/dev-haskell/listlike/listlike-4.5.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+MY_PN="ListLike"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Generic support for list-like structures"
+HOMEPAGE="https://github.com/JohnLato/listlike"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/dlist-0.7:=[profile?] <dev-haskell/dlist-0.9:=[profile?]
+ >=dev-haskell/fmlist-0.8:=[profile?] <dev-haskell/fmlist-0.10:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-haskell/vector-0.5:=[profile?] <dev-haskell/vector-0.13:=[profile?]
+ >=dev-lang/ghc-7.6.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+ test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-2
+ >=dev-haskell/quickcheck-2.4 <dev-haskell/quickcheck-3
+ >=dev-haskell/random-1 <dev-haskell/random-2 )
+"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-haskell/listlike/metadata.xml b/dev-haskell/listlike/metadata.xml
new file mode 100644
index 000000000000..4651de9eac1d
--- /dev/null
+++ b/dev-haskell/listlike/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Generic support for list-like structures in Haskell.
+
+ The ListLike module provides a common interface to the various Haskell
+ types that are list-like. Predefined interfaces include standard
+ Haskell lists, Arrays, ByteStrings, and lazy ByteStrings. Custom
+ types can easily be made ListLike instances as well.
+
+ ListLike also provides for String-like types, such as String and
+ ByteString, for types that support input and output, and for types that can handle
+ infinite lists.
+ </longdescription>
+</pkgmetadata>