summaryrefslogtreecommitdiff
path: root/dev-haskell/lifted-async/lifted-async-0.2.0.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/lifted-async/lifted-async-0.2.0.2-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/lifted-async/lifted-async-0.2.0.2-r1.ebuild')
-rw-r--r--dev-haskell/lifted-async/lifted-async-0.2.0.2-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/lifted-async/lifted-async-0.2.0.2-r1.ebuild b/dev-haskell/lifted-async/lifted-async-0.2.0.2-r1.ebuild
new file mode 100644
index 000000000000..cc55f2a91d80
--- /dev/null
+++ b/dev-haskell/lifted-async/lifted-async-0.2.0.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit base haskell-cabal
+
+DESCRIPTION="Run lifted IO operations asynchronously and wait for their results"
+HOMEPAGE="https://github.com/maoe/lifted-async"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test" # patch has a test failure: withAsync waitEither : FAIL
+
+RDEPEND=">=dev-haskell/async-2.0.1:=[profile?]
+ >=dev-haskell/lifted-base-0.2:=[profile?]
+ >=dev-haskell/monad-control-0.3.1:=[profile?]
+ >=dev-haskell/transformers-base-0.4:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ dev-haskell/mtl
+ dev-haskell/tasty
+ >=dev-haskell/tasty-hunit-0.9 <dev-haskell/tasty-hunit-0.10
+ dev-haskell/tasty-th )
+"
+
+PATCHES=("${FILESDIR}/${PN}-0.2.0.2-monad-control-1.1.patch")