summaryrefslogtreecommitdiff
path: root/dev-haskell/libxml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/libxml
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/libxml')
-rw-r--r--dev-haskell/libxml/Manifest3
-rw-r--r--dev-haskell/libxml/libxml-0.1.1.ebuild33
-rw-r--r--dev-haskell/libxml/metadata.xml11
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-haskell/libxml/Manifest b/dev-haskell/libxml/Manifest
new file mode 100644
index 000000000000..f7cc7e9cc62c
--- /dev/null
+++ b/dev-haskell/libxml/Manifest
@@ -0,0 +1,3 @@
+DIST libxml-0.1.1.tar.gz 3959 BLAKE2B 938bf1b309696574e47b4128dba8824ed9b756416980fa367269730051ff319c68ea8e49b9f4e63ab2da358f9a2ed9adc2f5a1f12cf729fbdd3b3ea48beedd10 SHA512 59a52200e7c7ab17a60a89e4a3aefdf6356e868be6be53696e5708a4d30863ae879834404ccfecb91b6d4b93a7ce0e147a3cc04bc4d5838c2aa990a290af5c5c
+EBUILD libxml-0.1.1.ebuild 840 BLAKE2B 406a0f50a64aba8cca8e1464bc52083bd265d4acd46d74ae6212ebde9b8cdb692036bf8df8a689ee4138bad387ef59e47e49c3208bcbd92694150b06452e7008 SHA512 a889413d67d2260180d27ad1b3ce3711a9b0da4e88160340effd5492225d92e75e1836db3f900eddeab41d529f49d724d97b222ac34d7e7bc494f109d357327f
+MISC metadata.xml 366 BLAKE2B cf690c286c302711b07f5cb346b0eaf848956797ac98040b21aefb53d10adb2c9bfd4ee37eecc5317f5c4b1bed79d7e896de919b566acf56a1bd2a99c46bd3e4 SHA512 45a7291c361e1689284f34e6b6321503ece79b7104cade450f688a88971563f36337ffb7bd54d576f0c5df974d68b907e386a9a4313f9948e82aab4c3b55e6f8
diff --git a/dev-haskell/libxml/libxml-0.1.1.ebuild b/dev-haskell/libxml/libxml-0.1.1.ebuild
new file mode 100644
index 000000000000..fba273ef96c5
--- /dev/null
+++ b/dev-haskell/libxml/libxml-0.1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Binding to libxml2"
+HOMEPAGE="http://hackage.haskell.org/package/libxml"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ dev-libs/libxml2
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0.3
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ sed -e 's@includes: libxml/xmlIO.h libxml/xmlmemory.h@pkgconfig-depends: libxml-2.0@' \
+ -i "${S}/${PN}.cabal" \
+ || die "Could not patch libxml2 configuration in ${PN}.cabal"
+}
diff --git a/dev-haskell/libxml/metadata.xml b/dev-haskell/libxml/metadata.xml
new file mode 100644
index 000000000000..3f3a10dd69c5
--- /dev/null
+++ b/dev-haskell/libxml/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Minimal binding to libxml2. Additional functions will be added when needed.
+ </longdescription>
+</pkgmetadata>