summaryrefslogtreecommitdiff
path: root/dev-haskell/lhs2tex/lhs2tex-1.19-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/lhs2tex/lhs2tex-1.19-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/lhs2tex/lhs2tex-1.19-r1.ebuild')
-rw-r--r--dev-haskell/lhs2tex/lhs2tex-1.19-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/lhs2tex/lhs2tex-1.19-r1.ebuild b/dev-haskell/lhs2tex/lhs2tex-1.19-r1.ebuild
new file mode 100644
index 000000000000..c3128315fe16
--- /dev/null
+++ b/dev-haskell/lhs2tex/lhs2tex-1.19-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+CABAL_FEATURES="bin"
+inherit base haskell-cabal
+
+DESCRIPTION="Preprocessor for typesetting Haskell sources with LaTeX"
+HOMEPAGE="http://www.andres-loeh.de/lhs2tex/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# dev-texlive/texlive-mathscience contains 'stmaryrd' font used
+# for guide generation
+RDEPEND=">=dev-tex/polytable-0.8.2
+ dev-texlive/texlive-mathscience"
+
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ dev-haskell/mtl
+ dev-haskell/regex-compat
+ >=dev-lang/ghc-6.12.1"
+
+# Setup.hs uses 'Text.Regex' available in both 'r-c' and 'r-c-tdfa'
+HCFLAGS+=" -ignore-package=regex-compat-tdfa"
+
+# datadir is /usr/share/${PN}/${GHC_VER} so mandir is ${DATADIR}/../../man
+PATCHES=("${FILESDIR}/${PN}-1.18.1-mandir.patch")