summaryrefslogtreecommitdiff
path: root/dev-haskell/juicypixels/juicypixels-3.2.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/juicypixels/juicypixels-3.2.8.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/juicypixels/juicypixels-3.2.8.ebuild')
-rw-r--r--dev-haskell/juicypixels/juicypixels-3.2.8.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-haskell/juicypixels/juicypixels-3.2.8.ebuild b/dev-haskell/juicypixels/juicypixels-3.2.8.ebuild
new file mode 100644
index 000000000000..51747e8f6015
--- /dev/null
+++ b/dev-haskell/juicypixels/juicypixels-3.2.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="JuicyPixels"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Picture loading/serialization (in png, jpeg, bitmap, gif, tga, tiff and others)"
+HOMEPAGE="https://github.com/Twinside/Juicy.Pixels"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="mmap"
+
+RDEPEND=">=dev-haskell/mtl-1.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/primitive-0.4:=[profile?] <dev-haskell/primitive-0.7:=[profile?]
+ >=dev-haskell/vector-0.10:=[profile?] <dev-haskell/vector-0.12:=[profile?]
+ >=dev-haskell/zlib-0.5.3.1:=[profile?] <dev-haskell/zlib-0.7:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+ mmap? ( dev-haskell/mmap:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag mmap mmap)
+}